Issue learning sorcery

I’m not wanting to submit a report just yet but I’m wondering if anyone else has encountered this issue.

We have several servers running that are clustered. Whenever a player learns sorcery, they are not getting the basic sorcery feat, the Arcane staff, the Thaumaturgy table, the ice Bridge spell or the reveal corruption spells feats. Instead they are getting an Arcane staff in their inventory, and the 2 Wisp spells (embed and Imbue I think they’re called).

Using Pippi, no matter what we do (giving feats, removing feats, etc) they are only able to cast the Wisp spells, even when we remove them. One player went so far as to delete his character and we re-created it. When he went and learned sorcery again, Wisp spells only again. So out of frustration we deleted his character a 2nd time, re-created it, he learned sorcery again and then everything worked.

Anyone encountered or even heard of this? It doesn’t seem to matter what server they learn sorcery from, it keeps happening.

These kind of issues need you to put your modlist up so that we have a better understanding of what is going on.

Ah, true. Sorry about that.

All servers:

°Frost & Flame Placables
°Less Building Placement Restrictions
°Pythagoras: Expanded Building
°Hosav’s Pets Extended
°Improved Quality of Life (IQoL)
°Immerse RP: Building & Decor
°Dungeon Master Tools (DMTools/DMT)
°Armor and Weapons Stats on Bench
°Alchemists Secrets
°Beyond Decor: Rustic Edition
°Simple Minimap (by Xevyr)
°Amunets Server Transfer

The servers this has happened on so far are on the Savage Wilds and Siptah maps

There have been some issues with Sorcery when overweight.

Also, I had a report using an older server may have issues, but a clean / new server will not.

For example, tested it on Single Player with the same mod list I have on the server, no issues (multiple tests). While on the server I had issues when it was raised in January.

Manually, to get around it, I gave the feats to players with the issue. No one brought up again on the servers so I have not followed up on it.

Good luck in looking into the issue.

Yeah we tried removing the Wisp spell feats from them and giving them the feats they should have gotten from reading the book to learn sorcery. They ciuld still only bring up the Wisp spells. So far the only solution has been to delete and re-create the character, which we have become very good at doing in about 10min lol

The Savage Wilds and Siptah servers are both less than a month old, but our EL server has been around for a year and 1 guy who learned it there said it worked correctly. Very strange

Aye it’s an odd issue. I wish I knew what was truly causing it. Since I did not, nor I could test it effectively since it was working fine in SP each time I tried it, I did the work around with Pippi.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.