Berserker refuses to use truncheon

Game mode: [Online |
Problem: | Bug |]
Region: [Here]

So my Cimmerian Berserker just flat out refuses to use a truncheon :man_shrugging:t2: Is this a known bug or am I doing something wrong? She runs up like she gunna do something but then just stands there and cops a beating :man_facepalming:t2: Did they make it so only certain thralls can now use the truncheon?


Steps on how to reproduce issue:
1.
2.
3.
4.

2 Likes

Hello @Darkzombie, are you giving your thrall any other weapon besides the truncheon?

If so, please make sure that he only carries one weapon by removing all weapons from the thrall and having him engage in combat unarmed, then giving him the desired weapon once he’s done fighting

If not, try resetting him by swapping weapons and having him fight, then replacing it with the truncheon.

Hi @Hugo no the only weapon she had was the truncheon. I removed and replaced numerous times out of combat with no results. I ended up clearing Asgarth, Mounds of the dead and storm watch all with my Berserker steadfastly refusing to do a damn thing. Funnily enough when I went to black keep and gave her a two handed star metal sword she was quite happy to murder away.

Thank you for clarifying, we’ll relay this information to our team!

Ive notice that if you leave a thrall with a truncheon before and after server reset it usually starts working but if you then equip a weapon it wont use the weapon

Berserkers comes naturally with 2h sword.
When you gave him the truncheon you “bugged” him.

And even as @Hugo said, this workraounds often DONT WORK at all. He/she refuses any other weapon-type.
Sometimes it works without problems and most of the time it will NOT. I have given up, as I was unable to reproduce its behavior.

I always wait for being out of combat. No enemy near. Weapon is unequiped (thrall has it in inventory). You replace the weapon and it sometimes works, but mostly NOT.

Only real fix is a server reboot… You reconnecting or restarting will do nothing.

I have my own thralls with 2h (sword or mace) and one with a truncheon or 1h axe.

1 Like

this has been happening with the relic hunters as well.

He had a 1h sword when i captured him.
Give him truncheon, he goes all political and will not help enslave his brethren.
Give him any other weapon, he goes to town. Such a hypocrite :).

1 Like

I noticed several months back that my berserkers don’t use the the truncheon well. Dalinsia and prisoners love it, so use them.

1 Like

I don’t usually have problems using my Votaries. Dal, she is a beast at Mounds. I accidentally died in a swarm there and she knocked them all out while I did my death run.

Sweet I knocked my first Dalinsia our last night so I’ll just stick to her for laying ppl out and the berserker for murdering folk. Cheers :+1:

What I usually do with thralls I want to go trunching with is to carry a 1-handed mace for them to use if I want them to resume doing lethal damage. In this way, it’s still the same basic class of weapon which seems to help with not breaking their combat AI.

FYI, this is also part of the reason why some of us keep asking for a 2-handed concussive weapon.

3 Likes

Put a torch also in their inventory, they will hit with the torch but switch to the trechoen more often then not. letting them get hit as well could trigger their reactions. Crappiest part is when you get there and have them just stand there looking dumb, been happening alot lately.

I pretty much exclusively use Berserkers, there are ways to keep your thrall from getting dementia and if you follow the list below you will likely not have them bug at all.

We’re going to call this a passive state.

When the thrall has their weapon out in hand we will call it active.

Never change a weapon when your thrall is in an active state. It’s going to be 99% chance to bug.

Most of the time you’re probably running away from a named NPC to keep your thrall from killing it. When you do this look behind you to see if your thrall is running backwards or facing the enemy while following. If it is, it will likely still have its weapon in hand. If you swap weapons at this time you’ll bug it. Try to find something else to kill to get your thrall back to a passive state. (Best way)

If you can’t kill something else remove a piece of armor from your thrall and replace it. This should move the weapon into the thralls inventory instead of its hand. Then swap to the truncheon. This works about 75% of the time. If this doesn’t work you can place the thrall on guard and repeat the process with the armor removal and replace them tell to follow again.

I only allow 2 weapons in the thrall ever, and always 1 at a time. Their killing weapon and the truncheon. If one is not working they are looking for the other. Allowing them to kill something with the one they want to use and then entering a passive state fixes the issue 99% of the time.

For the 1% of the time I break one of my rules I give them both weapons and let them choose what they want to use. While they are using it I remove the other weapon. Once passive switch to what I want.

If none of that works, which has never happened to me, but others have stated it doesn’t always work. A server restart will fix them up again.

7 Likes

@Wak4863 As usual a fountain of information man :+1::+1: thanks for the detailed work around she was in fact running backwards when I swapped to truncheon but no combat music so I thought I was safe to swap. I’ll do everything you suggested and see how she goes.

1 Like

Well I tried and I got it to work once :pensive: this sort of thing is why I keep leaving this game lol. I do a quick search and people have been posting about this problem since 2018. It’s nearly the end of 2019 and it’s STILL not fixed properly. And @Wak4863 whilst I genuinely appreciate the help a huge workaround by the player should not be the answer. This should be fixed. Period. Not by the player performing a bunch of steps to avoid the issue, but by the devs. @Hugo is there any particular reason why this and many other major issues with this game simply do not get addressed by your team? A lot of people like myself have dropped a lot of cash into this game and it’s frustrating and I gotta admit a little infuriating that funcom don’t seem capable of fixing some of the larger issues in the game but continue to concentrate on crap like mounts which I 100% guarantee will bug the living hell out of more than one aspect of the game when they drop. The salt is flowing at the moment I’ll admit but come on isn’t it time that issues like this that have been raised over and over get fixed PROPERLY??

2 Likes

If it’s any consolation at all, I have never broken Dalinsia. I have broken everything else by switching weapons, but not her.

2 Likes

I think that’s fair to continue to ask Funcom to fix the issue. My part of it can only be what’s in my control. That’s why I offer the work around for the time being.

4 Likes

Generally I find that if the thrall was using 2-handed weapons before taming, then they have issues using 1-handed w/o a shield equipped. The same also applies to those that used 1-handed weapons prior to taming, they have a lot of difficulty using 2-handed except for bows. If your thrall is having issues with using the truncheon, try throwing a shield on with it (any should work, i keep some dafari bone shields handy just in case). Its an annoying issue but seems not much can be done about it.

I did it this way:

I have Thralls with a Love Tap and Thralls with a weapon.
Every thrall takes on a single task.
No weapon change is made.
If I find an NPC named, I’ll go back to my base and get the Thrall, which is responsible for enslaving the NPC.
If I want to make a slaughter I take my fighter with a weapon.
So no problems arise.
This problem that you describe happened to me only when I switched from the weapon to the Love Tap.
Since assigning a task to each thrall, this bug no longer happens.

Conclusion: Never change the weapon, rather assign a task to each thrall.
:v:t4::blush:

For months before I found (or even belatedly realized) a named bearer thrall with the exuberant 9900 HP, I used my harem of delightful Dalinsia hotties to kill & capture everything. She’s only around 5400 hp but has always seemed to work very well over all.