Thralls are useless after weapon change

Game mode: [Online | Multi-player]
Problem: [ Bug | Misc]
Region: [Here]

Ok so i know this might not be an issues with some but i get this all the time and it really annoying. There are times i want my thrall to use certain weapons and if i ever change it’s weapon i have about a 70% chance that they will become completely stupid and not attack again until after server reboot next day. Can you please look into fixing this and if you need an idea on how. Just add a equipment clear button for the Thrall’s and it fixed if they think they have nothing and you give it all back to them problem solved. You can even make this part of the game call the button strip and you strip them of everything they have. Thank you

Steps on how to reproduce issue:
1.Change Thrall’s weapon

1 Like

yea confirmed, ive had luck by givin them the weapon types that they are spawned with. best for sword /shield ppl to use the truncheon btw. quick fix is to try “take all” their inventory then replace weap to first slot(s) bc if ya give them somethin to hold while their weapon is equipped, when they unequip it, they get all discombobulated.

Are you making this weapon change right after placing them or are you switching weapons while doing runs? Like switching from a sword to a truncheon, so that you can knock out a NPC instead of killing it.

The reason I ask is because they are different “bugs” there are times that it seems thrall prefer certain weapons. The other case is when switching weapons during combat the thrall can bug and be searching their inventory for the other weapon.

Both cases can have a couple fixes.

  1. Remove helmet and replacing it can fix the issue.

  2. Give them the other weapon back and let them complete a battle and put the weapon away then switch weapons.

  3. Simple remove all weapons and let them punch until they decide to stop then replace the weapon.

I’ve had luck using all of these steps sometimes one after the other until the bug disappears

Thank you for the reply i tried steps 2 and 3 not 1 i will try that next time but still a clear thrall button would be so handy in this case

Hello @agfike, thank you for getting in touch, as well as to anyone who shared their feedback!

Could you also provide all the steps you usually take to change the weapon on your thralls and, if possible, reference any thrall and weapon combo you have tested that caused the issue to occur?

We’ve forwarded this data to the developers for further investigation, please don’t hesitate to let us know if you have any additional findings in regards to this matter.

1 Like

@Hugo Thank you for replying so much. The thrall that I use is a bearer. I like to switch between a truncheon and normally a spear. I have also tried removing there weapons to have them sit there and just look at the enemy as if sizing him up. I have not yet tried the removing of the helmet tho. When the thrall is really stuck i have tried giving him my weapon as well which i use axes and i carry a two handed mace that i also tried to change and it would still not attack.

As for the let the use there hands it don’t work most of the time for me. But i have had it work a few times.

Around 90% of the time when this happens to me I have to wait for a server reboot to fix it. And i have to have a weapon i want the thrall to use equipped before reboot. Most of the time I have to keep two thralls with a permit weapon and run back to house to change thralls. This sums up most of the things i have tried I will write back if i think or try anything else.

Thank you again and if you have follow-ups sign me up :grinning:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.