Thrall not attacking issue

Game mode: [Enter game mode here: (Online official | Online private | Single-player)]
Type of issue: [Enter one of the following: Crash | Bug | Performance | Misc]
Server type: [Enter one of the following: PvP | PvE-Conflict | PvE]
Region: [Please enter your server region]


I know you’re already aware of the issue. I believe it’s tied to the weapon itself.

I had two fighter thralls to work with. In the cases
where the thrall isn’t attacking I would take the weapon from the thralls inventory and give him a different one and he’d attack without issues. Then go get the other thrall and he’d attack fine but when I gave him the bugged weapon from the first thrall he’d just stand there until I gave him a different weapon.

[Describe the bug here]


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:
1.
2.
3.
4.

2 Likes

Hey @Swampdaddy0, welcome to our community.

We’re aware of this issue as you mentioned. We’re looking into it. Apologies for the frustration until we provide a fix for it.
Thanks for your feedback :slight_smile:

3 Likes

Please don’t derail other topics. Open a new thread if this issue hasn’t been discussed recently.

1 Like

I’m still having this problem also. Saw some others on my server talking about it. This seems like one of the biggest issues in the game period it makes playing extremely difficult at times & super frustrating.

I agree it seems to trigger when you swap/remove weapons on a thrall.

Is there any update on this? it seems there has never been a point in the game where this wasn’t an issue.

3 Likes

Issue seems worse after patch, mi Pet is just watching me fight.

2 Likes

I have tested this as before the latest patch 25/06 Thralls would at least work somewhat like they were supposed to, now they just don’t seem to work. I did observe the following:

I have broken some new thralls to test, took them straight out not touching their inventory and they just stood an watched. They do take their weapons out and approach then back off but never attack.

Added armour same result as above.

Changed the weapons to the same type but legendary - they attacked for a couple of times then reverted their behaviour of just watching. On one occasion Daicus attacked by punching and not using the weapon he had. Changing the weapons again does not seem to get them angry and they still just watch. After a server restart this seems to reset the behaviour and you get a couple of attacks out of them if you change their weapons.

Change the weapon to a different type and the behaviour resorts to the just standing there with the weapon out.

Not tested pets as I don’t use them.

2 Likes

Yeah this is brutal. For my part this is the worst bug in the whole game. Having Thralls function properly is one of the most important parts of the game. I’d really like to see funcom talk about this bug more & talk about squashing it definitively.

Funcom, has there been any work on this recently? Is it possible we could see a fix soon?

2 Likes

I can certainly understand and share the frustration. Let me reference a post that discussed this a while back…

You will find a link to Trello where someone said they could not reproduce it and it may be fixed, lol.

Even though I gave them specific directions on how to reproduce the bug, the Trello card has not been touched and says the same thing. Were I a member of the team, I would pass right over the issue and move on, just based on someone not paying attention to the playerbase or the complete instructions.

While I realize the importance of correcting the massive setbacks created by the exploiters, certainly there is one person available and capable enough to reproduce the bug.

Color me livid.

jim

1 Like

Yes I have to say this is becoming more and more of an issue for me on our server. And it dosent seem to even be tied to weapon switching, or switching between a 1h and 2h weapon on a thrall. Earlier I took out my Bandit Leader, and a Relic Hunter later and both seemed to have no problem attacking correctly when being attacked or attacking an enemy. However a short time later I went to try to do something new up in the mounds area and any time combat was engaged, they would figure out there was combat after about 5-10 seconds, then run twords the enemy, but then just follow it around without ever actually attacking at all. Took them both back down to my base area and had the same result trying to get them to attack even the low level mobs in the area I am in. So this is a random issue in the sense that a thrall that was working perfectly fine only a few hours ago now is a complete idiot when it comes to attacking anything. I want to say that perhaps it’s tied to the random giant 2 second lag spikes I have noticed becoming more and more prevalent on servers but I have not even found out any type of pattern to these lag spikes themselves. Does not seem to have anything to do with in game activity or lack thereof, they simply seem to happen randomly every few seconds on a constant basis, sometimes spiking over the 1000ms range when I normally show a 110-125 ping on this server. Not sure what’s going on but it seems like the place I never seem to have this problem is in a solo game, even with aprox 10-15 mods running on my single player game.

1 Like

I have this problem in a solo game (single player game). This is sad.

1 Like

The original bug on thralls seemed related to weapon swap, because if you give previously working weapon to the thrall usually he start again to fight.

But after last patch I noticed also pets (I never had this problem before) are now often refusing to fight.

EDIT: time ago it happened sometimes when the server was almost full, but that afflicted all AI controlled things: thralls but also NPCs, animals and monsters, now it seems to affect only your thralls and pets… wich is worst :sweat_smile:

1 Like

Don’t give them more weapons than needed in inventory.
For thralls more choice isn’t better. :wink:

In my current test and playtime these last days, i didn’t mention any special problems with thralls/pets not attacking.
But i stuck still to my theory, and give them only similar weapons they come with. Better of course, but still same style.
All my recent tests are based on singleplayer actually, so i can’t really tell right now for server behaviors.

But i’ll try to turn some tests more next night. Simply to hot over the day, i’m sorry ! :sunglasses:

1 Like

In my case, often they use truncheons or fists when given choices. I tend to limited the weapon depending on what I want, knockout or death.

Still, having said that I am fed up with unresponsive thralls. They equalize my ability to play solo and are extremely unreliable. I don’t mind soloing the red mother, it takes longer and damages my equipment more, then I have to heal my thrall who just stood there getting slammed. At least she served a tanking role allowing me to focus on damage.

Respectfully, Shadoza, my experiences are the same as Vattende.

Still livid at the lack of attention with this issue. Apparently all it takes to sideline a problem is the statement ‘cannot replicate’ to ignore a large part of Funcom’s supporters.

Also apparent is the fact that @Jens_Erik prioritization in November of last year had no effect.

I am a huge supporter of CE and Funcom, but this issue affects a large number of your customers, folks.

Although this is my opinion, I think it represents a large populace.

jim

4 Likes

On PvP, thralls and tames (AI), I believe were intended to be the main offline raid defense besides a bubble. Babysitting things that should take care of themselves is not fun.

1 Like

they do swap & hesitate unnecessarily when given multiple weapons, but that’s not the bug. The no-attacking bug has happened for me when they have only 1 weapon.

Is there any dev update on this bug? I can’t help but think this is & has been the worst bug in the game. & it’s pretty common.

1 Like

That’s my own experience, and i played lot around with weapons and thralls.
But let it or keep it, i know you follow you verry own personal gamestyle what ever we may suggest you. :wink:

1 Like

Yes, to much weapons make them just confused mostly, they don’t really know what choice means.

Did some tests and fights this late night or early morning (whatever :wink: ), and could experiment again some problem with some big animals and ennemis. When thralls get heavingly slashed, pushed around, like it’s the case with elephants, rhinos and such, they may lose by moment the abality to fight. In my tests, mostly the abality went back quickly after. Or after the fight ended, or a small walk.
But i know, some players need remove the weapons, and give them back when this happens. Again may differ from game to servers, and depending game or config, who knows.


You may find something that helps you fix your individual case, or not…

No, not Swordof Crom. I’ve swapped it out for other weapons and got the same result. Thralls are just not working properly, plain and simple. This is a major problem that needs to be addressed ASAP or lots of people will just stop playing.

1 Like

After further experimentation I’ve come to the conclusion that the problem is with fighter thralls. I fought the giant spider with two different fighters, and in both cases they generally just stood around and maybe took a swipe or two with their weapons. Tnen, just out of curiosity, I tried the same fight with a T4 bearer and he worked normally … was aggressive and did all his combos.

I don’t know how archers would do since I don’t have any T4 archers. In any case, I’m pretty sure the problem is with fighters.