Black knight armour siptah

Hi all.
Am in need of some advice.
I went to the judge, killed it, got the black Knight armour recipe, used it, learned it.
How do I craft it?

I have an improved armourers bench and a Harrison’s bench…both have llor the accursed armourer thralls but there’s no mention of the black Knight armour in the crafting inventory.

Help!

Is your character level 60 with (the prerequisite) ‘Exile Epic’ armors unlocked?

Yeah. I have unlocked basically everything I can.

Are you trying to craft it from an Improved or Epic Armor’s bench, not just the basic one?

Yes. As I originally posted, I have tried improved bench and garrison bench. It doesn’t appear to be there.

Apologies for asking, are your filters ok?
Sometimes we change by accident our filters and we cannot see some recipes.
In order to check if your filters are ok you must see on top right of your screen " show all".

That’s a good tip…I’ll have a look in a bit.
I also can’t seem to find frost giant armour which I have definitely learned

1 Like

Checked filters. It says show all

1 Like

@DaVice @stelagel Black Knight epic version seems to be bugged for many newer players. If you learned it a while back, no issues. However, if it’s somewhat recent, it doesn’t seem to be showing. This topic has come up quite a bit in recent months. Not sure if Funcom has formally recognized it or not though.

4 Likes

My suggestion is to return to whichever knowledge point is more accessible to you physically, though I’d prefer if you went to obtain new knowledge instead. The stones in the Arena would be ideal.

I have found this to be the case in many instances of a new character: it requires more than one touch of the stele or knowledge stone in order to register the new recipe. Please keep an eye on, and/or screenshot your ancestral knowledge area, as all your current acquired or purchased knowledge will appear there.

Have you gone to get Kurak yet? Did it register by unlocking Sorcery to you, and adding to your Ancestral Knowledge?

1 Like

He’s on siptah :neutral_face:

2 Likes

Well that’s a bother. I missed the Judge part, and took the armor for Legion.

It would still be interesting to see if Ancestral Knowledge does update in the base game. Thanks for the correction!

1 Like

I’m assuming you’re referring to the list of knowledge on the last tab? Ancestral Knowledge is where all the Bazaar and Battle Pass items show. Regular unlocks are either in the Esoteric section (voidforge armors and weapons) or in the armor or weapons sections (black knight and vault armor/weapons, etc.).

1 Like

I’m saying Ancestral Knowledge as any acquired knowledge during the player’s reroll (new character progression) that doesn’t get wiped by Lotus, which is probably out of date. EDIT: In other words, I was using it backward. If your Ancestral Knowledge is correct, and acquired essential recipes like Sorcery are correct, there may be a deeper problem.

I’m meaning basically anything that is acquired during the new character’s growth. What I’ve found is that after many, many recent Exiled Lands playthroughs, some of the acquired recipes are not registering until after the second press of the stele. And by watching my acquired recipes and knowledge (usually in the Search tab, I think), I can sometimes see whether I need to press the stele again.

When we had more PS4 players, these sorts of misregistrations (especially if they happen in both Siptah and Exiled Lands) were signs of a need to make cloud saves, and reacquire the Conan Game Files.

2 Likes

Yeah, I think the yellow lotus potion broke sorcery progression for a lot of players though. Not sure if there was ever a solution to that. I didn’t have any issues since I was aware of the loss of recipes prior to leveling sorcery. Many people, however, were stuck with no way to continue it. They even tried to unlock sorcery again, but that didn’t work. Hopefully it got fixed because, as I understand, the only way to fix it was to recreate your character.

So basically I can’t access the recipes because of sorcery? I haven’t used yellow lotus potion so it can’t be that.

No, I clouded the water by asking for Exiled Lands information. Having had to re-download the PS4 game files on a slow connection, I was trying to see if there was maybe something else at play in your issue. My point was to investigate and find a solution that does not have you redownloading the game.

Is it possible for you to go back to try and reacquire the recipe?

1 Like

8 did try once but I think it’s a random drop so I may have to try a few times!

1 Like

No, Black Knight can be acquired as a guaranteed drop if you delve for it. Use a Grandmaster Armor Patch kit on a piece of looted Silent Legion, then delve it. You’ll get it guaranteed. It’s how I was able to bring it over to Exiled Lands during the transfer period.

5 Likes

Sweet. I’ll try that. Thank you

1 Like