Blood and sands DLC doesn't work properly

Game mode: [Online + Singleplayer]
Problem: [Bug]
Region: [EU]


I bought the Year 2 season pass shortly after the Turan DLC was released. This DLC works perfectly, but the newest one, Blood and sands, doesn’t. When I’m ingame, in the feats menu, it’s shown, as if I hadn’t bought it, eventhough I own the season pass. I would love to use the new building pieces, but unfortunately I can’t.


Steps on how to reproduce issue:
Actually I have no idea xD

You have it downloaded but may need to go back to psn and click it again others have had this problem. I believe that is how it was fixed.

Hello @tobi04, welcome to the forums!

Please make sure to download every DLC from the store in order to unlock it in the eventuality that it isn’t unlocked. If that doesn’t work, try to re-validate your licenses through the Playstation settings.

Ok. thank you @sestus2009 and @Hugo. I’ll try that out later.

Returning after nearly two months not playing the game, I had the same problem : I could see the content of Blood and Sands DLC in the feat menu but could not get it while I’ve bought the Season 2 pass. I did what’s in this thread : try to download it from the store, but that wasn’t possible, the download didn’t start. Then I re-validated my licenses from the PS4 menu… And it worked ! I was able to craft the short sword, 2h axes and war axes from the DLC.:heart_eyes:

2 Likes

Perfect. I’ll try out both methods tomorrow (unless the first one works :wink: )

I had the same problem as you described, @Wolfrider4594 : The download didn’t start. Then I tried @Hugo’s solution, but it didn’t work either. I also bought Year 1 season pass yesterday which worked totally fine.

For me it worked after I went to the PS4 menu and used the re-validate the licenses option in it. Of course I did that after closing Conan Exiles game.

That’s what I did. I’m gonna try it again, but if it doesn’t work I’m gonna contact the support

I tried out all of your suggestions, @Hugo, @sestus2009 and @Wolfrider4594. None of them worked. I have the same issue with the “debaucheries of derketo” - DLC. (I didn’t try out solutions for this one yet). Are there any other suggestions to get this thing working?

@tobi04 last night I purchased Derkto renewed license went into game it works. I have not bought a season pass. Try going into ps store again and hit download. Good luck.

1 Like

As a last resort, could you try to reinstall the game?

Also, are you using an internal or external drive?

I didn’t try the new one out yet, but I think I’ve only got these problems because I bought and downloaded the season pass before all DLCs were released. The Turan DLC worked perfectly fine because it was already released when I bought the season pass. If you buy them one by one it should work fine.

I also thought about it but I didn’t want to do it because my internet is really bad at the moment. If I re-install it, will it effect my stuff on online servers?

Internal. I’m just using my normal 1TB PS4 drive

Reinstalling won’t affect any of your characters or items in online servers, as that data is saved in a server side database.

1 Like

That’s what I thought. Thank you. I’ll try this out when I come home on sunday

1 Like

And for a Solo / coop game you can force your saved files on the HD to be transferred to the cloud if you enabled the cloud saving.

I’m like you I bought the Season 2 Pass after the release or the Turan DLC and this one worked fine but the two next didn’t. For Blood’n Sands I had to reinitialize my licenses for it to work. and for Débaucheries of Derketo I only had to go the PS Store to download it, even if nothing was downloaded, for it to work.
Sorry that didn’t workd for you. Both DLC are great imo.

2 Likes

I’m not at home at the moment but when I’m back I’ll try out @Hugo’s suggestion:

This should work because the download should automatically download all purchased DLCs (which is everything besides riddle of steel for me). If this doesn’t work for some reason, I’ll try out your idea:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.