Can not download Blood and Sand pack

Game mode: [Online | Singleplayer]
Problem: [Crash | Bug | Performance | Misc]
Region: [Here]

It says it’s free, as I own the season pass. However, when I select download the flashes, screen dims very briefly, then it just acts as if I never clicked it? I just downloaded this montha free games so I dont think it’s on my end.

Steps on how to reproduce issue:

  1. Load store
  2. Search conan
  3. Find dlc
  4. Fail to download


I’m having the exact same issue

Friend of mine said this worked for him.

  1. Install update
  2. Start Game to main menu
  3. Quit game
  4. Go to store and click download.

Let me know if this works for anyone else.

(EDIT) So even though when I clicked download it just blacked the screen and went back once I loaded in the game the building pieces were in my crafting menu.

It’s like every other DLC pack for Conan Exiles, it doesn’t download technically, all the download button in the Store does is give you the “unlock key” for it, the actual data for the DLC is in the patch.

What I mean by unlock key is that by choosing download for it, all it’s doing is unlocking the normally locked content that was added in the patch.

It could also be that you overlooked the DLC stuff in-game too, it doesn’t have a different coloured background to it’s icons in the crafting and feat menus, same black and red background as the standard content.


Hi @MaxStone.
I had the same pbl yesterday. The below solution worked. I just had to wait for the full download of the patch to be able to see the dlc content.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.