Bug\ Can't target robot boss to begin combat or loot El Generator in Lair of the Horned Devil

I dispatched all the enemies without alerting the MIMIR robot boss and now I can’t seem to fight it at all and nor can I loot the EL Generator artifact.


I’m pretty sure you have to kill the Mimir and clear the zone of hostiles. Thing is you can’t ambush the Mimir because it’s not hostile so you need to take it out before the last Ghoul.


I can confirm that after the most recent update I have now gone back and have been able to pick up the El Generator artifact. The robot no longer counts as an enemy on the map if you cleared the enemies before it was activated and the Generator console is now functioning as a lootable artifact correctly. It appears my particular bug has been fixed. Thank you :slight_smile: Was able to collect the achievement for an easy 100G!

No, that was a bug.


  • El Generator Artifact can be collected even though the Z600 is still ‘alive’.

El Generator Artifact is still broken on PC :frowning:

I’m just asking to make sure, but this is still bugged even with the latest version of the game (Stalker Trials update)?

Yes. Just got the game for the other day on PC, been loving it so far. Just got to the horned devil fight. The bot was activated in my fight and it killed the last ghoul. I then killed it, it exploded, destroying the platform one of my mutants was on, who fell to his death. Since the bot was the last enemy, he was instantly revived but the WILL DIE IN 6 TURNS message was still stuck hovering over his character model. I couldn’t pick up the artifact. Then I loaded to the autosave right after the fight, the message disapeared but the artifact still couldn’t be picked up.

So I’ve just cleared the Lair of Horn Devil? map without any of the enemies alerting each other and as a result, the big Mimir unit in the warehouse is not triggered. I cannot proceed with the story as I cannot activate an ambush against the Mimir unit because the unit is still unpowered. Please fix the bug so I can get the relic!! Thanks!!

Isn’t that just an optional area?

Ah yes, you’re absolutely right. I just want to get the purple relic sitting right in front of the warehouse. I’ve edited my post. My bad! Still can’t get it atm.

Yeah, i ran into the same issue… it must be because they didn’t expect you to be able to do it? i would post images, but i’m too new to be allowed that… I Hog rushed the Boss, and killed her before she could get up to respond/ call for help, and was then able to snipe everyone from the top of the building with silenced weapons and good timing

1 Like

Imgur links work

Same here even though the mimir did activate, unable to get the relic

Same here, even after today’s patch (dec 10)

Mine doesn’t… i got myself an Imgur, but it won’t let me post the link at all… probably because newbie, again

I have the same problem. I cleared the map without activating mimir and can’t get the El Generator. Mimir is marked as a red dot on the compass but there’s no way to trigger the fight or to get the artifact…
C’mon devs, 3 months since the bug was reported and still no fix, shame…

Got it, thank you very much. I will report this back to the dev team :slight_smile:

It could be that the Stalker Trials update rolled back the previous fix we did.

EDIT: Merged two threads together, so my apologies if the dating on some of these comments don’t make sense.

This is still an issue on PC 1.07-353_CL-20563

I stealthed everybody on the map and activated the computer terminal somewhere in the middle.

The bot shows as a hostile on the radar but is not active, and I can’t pick up the artifact.