Can no longer access game's website


#1

I can no longer access the game’s website to purchase credits or to check on my subscription. It’s just my family and I that play, but I’ve talked to Funcom customer support and was told, to make sure that I’m not behind any VPN or any proxy address, so I checked and I found out that I wasn’t behind one, I informed them of that, and haven’t heard from them since.
If you have any suggestions that would be great, Thanks!


#2

What happens when you try to access the website?

Have you tried from a different computer or a different internet connection? Like on a cell phone, or a work computer?


#3

I have tried to access it from a different computer on a different internet connection and I get the same result.


#4

And what happens when you try to access the site (https://register.ageofconan.com/account). Does this page load?

Are you allowed to enter a username and password?

What happens when you do? Does it display an error?

Maybe you could screenshot the page to show us what is going wrong.

Also, what web browsers have you tried to use?


#5

Whenever I go to https://register.ageofconan.com/account The page loads.

I can enter a Username and Password.
After entering them, and trying to login an error message appears saying 'Are you sure you typed your password correctly? Also make sure your [CAPS LOCK] key is not active.'
I’ve tried using the Browsers: Microsoft Edge, Mozilla Firefox, Internet Explorer.


#6

And you are completely and utterly sure the password is being typed correctly? You can type it in plain text in a text file and copy/paste if you are unsure it is coming out correctly and want to visually verify.

Have you tried the password reset option?

Also, out of curiosity, what country are you in?


#7

I had a similar problem with my account. It was working on my phone but not on my computer for some odd reason. I would suggest you to try it on your phone because after I was able to log into my phone it worked on the computer again.


#8

I am completely and utterly sure that my password is being typed correctly. I have tried the password reset option, I was given a temp password, I tried it, the temp password didn’t work either. I’m in the United States.

I just tried to log in to my account on my phone, that didn’t work either. Any other suggestions.


#9

Well… I can’t think of anything else to try.

I wonder if you could even create a new account and log in with it. That would tell us if the problem was somehow your old account or not.

All I can see is that either:

  1. Your account is broken internally.
  2. All your devices / internet connections you’ve tested all have the same problem preventing your access.
  3. User Error.

It seems likely to be Problem 1.