Cannot log in via Steam (again)


#1

I was able to play earlier today, but have been unable to log in since about half an hour ago.

Clicking on the red Login button leads to a long “authenticating…” popup and then an error message that the game “cannot connect to the login server, check connection or firewall and try again.” Nothing has changed in my connection or firewall in the past couple of hours. Restarting launcher or steam, or clearing steam cache have not made any difference.


#2

Same here.

Happened just now after an update on my steam client.


#3

Same for me, help us Funcom please… it’s an event w-e…


#4

Has been happening for me too all day. First time I tried, I got in on the fifth try, but this evening I tried for ten minutes before giving up.

That said, Steam itself has been playing up for me too (losing connection).


#5

Yes, the Steam Authentication servers were screwy earlier, but they seem to be cleared up for everyone now.


#6

I managed to pass the login after, several times, emptying the steam download cache.