Cannot Place block


#1

So for some reason the game will not let me place a bock in 1 specific location. I created a circular floor for a tower. Every single piece snapped into place perfectly. I have 1 open spot left and for some reason I just cant place anything there. I tried breaking out surrounding blocks to make sure nothing was in the way or overlapping, but still cannot place a block there. I would love to show a screenshot, but the forum won’t allow me to upload an image or even share an imgur link. Please someone help.


#2

I see this issue occasionally. Placing another foundation near the affected spot typically fixes it.
Relogging does too, sometimes.


#3

I’ll try the foundation block trick, but it’s the second floor that has the issue. Not sure if it will let me place a foundation block there. I’ll post again once I’ve tried it out.


#4

Yeah, there just isn’t a way for me to place a foundation block near where I’m trying to place my tile. I did try reloging and that did not solve it. Not sure what I’m gonna do. Will have a permanent hole in my second floor. Thanks for replying though.


#5

Is it a foundation or a ceiling tile? If it’s a foundation piece, try crafting a ceiling piece and hovering the wireframe of it in the same location. If it’ll go there, switch to the foundation block, and that’ll clear the bug.

If it’s a ceiling tile you are trying to place, craft a repair hammer and check the surrounding tiles. If those tiles are at 20 or lower, you need to drop pillars to support the ceiling.


#6

It’s a ceiling tile. I tried using the pillars for support already and it didn’t change anything. Still left the spot implacable.


#7

Hmm actually now that I’m looking at it with the repair hammer, the pillars aren’t changing the stability for some reason. That must be the issue.


#8

WOOO ok got it figured out. The way I had made my second floor using the triangle ceiling tiles was not connecting to the stone pillars, so they weren’t effecting the stability. So I made some of the diagonal wood support struts which did the job. Thanks for the help!


#9