Cannot place vertical elevator

Bug Description:

Cannot place vertical elevator, says invalid end point

Bug Reproduction:

Try to place a vertical elevator on a 6 block high foundation.

I cannot place a vertical elevator anywhere, but the horizontal ones seem to work fine.
I had no issue with them before sorcery was added, now they won’t place.

Hello there @LonePlayer!

Thank you for taking the time to report this situation.

Regarding this, would it be possible for you to please provide us with a screenshot of what shows up when you try to place the elevator vertically?

I cannot unfortunately paste images because of my account status being “new”.

Thank you for your reply @LonePlayer!

You should now be able to post images on the forums.

The elevator just refuses to snap to anything, no matter what I do.
I have turned it every which way, tried different foundations, tried walls, and it does not allow me to place it.
I even went to another part of the map where I had other building items and it wouldn’t snap to anything there either.

Oh and yes those heights are at least 5 or more blocks high which is not really shown in the pics.

Seconded. Had no issues putting down elevators before 3.0; now I can’t seem to put them ANYWHERE, like literally nowhere works.

Playing on PC

I posted about this on testlive and got a response that it was a known issue and they were working on it.

The elevator just doesn’t snap to anything. A while before 3.0 I had an area where I had built a platform extending out from a cliff consisting of a foundation block and a row of ceilings with the elevator at the end of that. Very simple and crude, but effective as a means of getting up and down the cliff without building an ugly staircase. Especially for the early stages of base construction.

But even that doesn’t work at all anymore. Even building a platform below for the endpoint doesn’t work.

Same problem here. But it seems, it has something to do with altitude. Stacking 8+ foundations on top of each other always lets the elevator snap. Oddly enough, the problem doesn´t seem to occur in flat map regions at “sea level”. Near the the river, for example, i can still build elevators, regardless of foundation height.

Tearing my base apart, I think I’ve come to the same conclusion. There’s one spot that I need that just doesn’t work, yet I can get it to work exactly right if I just move the level up or down by 1 wall/floor.

Hello everyone,

I also have some of the same problems as described above.
The error occurs to me both in single player and in multiplayer on the official servers.

For me it seems that since the 3.0 update sometimes the stability is not calculated correctly. In various cases I was able to “fix” the error by tearing everything down and rebuilding it. However, the chance that it would work was only 50% for me.

I also noticed that the elevators don’t seem to get along with the foundations. When I used ceilings, it usually worked out somehow afterwards.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.