Vertical Elevator bug

Basic Info:
Platform: Steam
Issue Type: Gameplay
Game Mode: Single Player
Map: Exiled Lands
Mods: No mods

Bug Description:

It seems I cant’t place vertical elevators since 3.0 it doesn’t snap to foundations anymore, if I try to remove and replace an elevator placed in the world before patch 3.0, I can’t. The horizontal elevator works fine.

Bug Reproduction
craft a vertical elevator and try to place it on a 3 foundation tall pillar

Greetings Exile,

Thank you for reaching out. Can you confirm if you were trying to place it by using the construction hammer or directly spawning the item and trying to place it? As we see some elevators in the image, in the Hotbar.

We await your reply.

1 Like


I crafted the elevator from the carpenter’s bench and then I tried to place it into the world from the hotbar, no construction hammer involved.

I’m having a similar problem and I’ve been throught some posts on steam.
It seems it’s a issue only in single-player game, with both normal and fast elevators.
For some reason, people are telling that the elevators only works from a “minimum threshold”.
Some people say that the elevator only worked from 8 blocks high while others say it worked only worked from 10 block high.
In my single mode game, the elevator only seems to work with 8 block high or more.
I guess it’s a wierd bug, since people are saying they seem to work fine on multi-player games

1 Like

I wanted to verify if the bug persist on a brand new map, so I started a new single player game on Siptah and there I was able to place any elevator.
I guess my single player “exile lands” map is bugged for some reason but I don’t feel like to wipe it to see if it can be fixed :expressionless:

However, just like you wrote, if I place the elevator on a 8 foundation pillar it works on the exile map. Thx for your reply!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.