Can't consistently connect to Official Server

Game mode:Online official
Type of issue: Performance | Misc
Server type: PvE
Region: US - West Coast


[Describe the bug here]
Ever since the horse update I haven’t been able to consistently connect to the Official Server I play on. When I try to look for it in the server browser, it doesn’t always pop up. Other servers will fill within the browser, but not the one I play on. I’ve even tried direct connecting and it will tell me the connection failed. I’ve tried connecting through steam’s servers and I’ll get “server not responding” I’ll have to refresh 50+ times within Conan’s server browser before the server finally pops up and I can play.

I’ve tried all the troubleshooting in “Common Technical Issues and solutions” thread and nothing worked. Even re-installing the game didn’t fix the issue. I’ve messed with my firewall to see if that was the cause of my problems, which it wasn’t. I’ve checked to see if any changes were made within my network to see if that was the problem, which nothing had changed.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:
1.
2.
3.
4.

Could it be a ping issue?

The server I’m trying to get back on is roughly 40 ping. I’ve never been ping gated on that server before.

Sorry about your connection issues ive had numerous ones myself, but i have tried tirelessly to have funcom work with steam, to have steam show the pings of other players so we can see if there’s hackers or not(high pingers most likely hackers) and when did you guys let up on high pingers anyway?, battlemetrics may also provide good clues if theres a hacker or not

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.