Can't craft any DLC Armour or Building peices even though I can see them as learned in my feats

Game mode: [PC: (Online official )]
Type of issue: [ Bug ]
Server type: [ PvE-Conflict ]
Region: [Oceanic]

On the 15th of March 2020, I was unable to see any craftable DLC armors in my Improved and regular armorer’s bench. I checked my Feats Page and I knew them. I then tried to look in my crafting tab to see if I could make any DLC building pieces. I could not see them. I checked my Feats page and it was the same. I had learned them, but could not see them in my crafting tab. I have had these DLC’s for a long time. This is the first time that I have been unable to craft them.

  1. I went to the Black Knights Dungeon and learned Silent Legion armors and weapons.
  2. Later in the day, I tried to craft Pictish armor in the improved armorer’s bench.
  3. I could not craft them, so I checked my feats and I could see all the DLC armors and they were green ie learned.
  4. I tried to craft a pictish foundation and there was no pictish craftables showing.
  5. I checked my Feats tab and I could see the Pictish building pieces as learned under construction.
1 Like

When this happens first thing I try is to relog. If that does not fix it. Empty your players inventory to storage and remove the bracelet. Then relog. All feats will be restored.


Thanks that sounds like a good fix, but it righted itself overnight. :smiley:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.