Old DLC content shows in Feats & Construction Hammer, but not in benches & Inventory

Game mode: Online official
Type of issue: Other
Server type: PvE
Region: US
Mods?: No (official server)
Edition: Epic Games Store


Bug Description:

Old DLC items are not appearing in craftable fields, despite still appearing in Feats and Construction Hammer.
What is missing, specifically;
• the fodder+pet skins in the Inventory,
• the fodders themselves in the Precision Alchemist’s Bench {have not tested other tier Alchemist’s Benches},
• all old DLC armors in Garrison Armorer’s Bench and Improved Armorer’s Bench {have not tested tier 1 Armorer Bench},
• all old DLC weapons in Garrison Blacksmith’s Bench and Improved Blacksmith’s Bench {have not tested tier 1 Blacksmith’s Bench}

What still seems to exist, specifically;
• All old DLC building pieces’ skins in the Construction Hammer,
• all “[old DLC] Mason” Feats under the Knowledge > Cornerstones (house icon)
• ^^^^ under Knowledge > Construction (hammer icon) > “[old DLC] Mason” heading
• All old DLC fodders under Knowledge > Survival (campfire icon) > Stone Tools heading
• All old DLC weapons under Knowledge > Weapons (swords icon) > pretty much every relevant heading
• All old DLC armors under Knowledge > Armors (shield icon) > pretty much every relevant heading

What I haven’t tried yet:
• checking if the DLC items are also missing from the Artisan Benches
• Potion of Natural Learning (I was hoping to avoid having to re-sink all 1700+ points back into my feats. Or worse, have the last remaining proof of my DLC purchases disappear before reporting this incident)

If I’ve left anything out, feel free to ask.

What I HAVE tried;
• asked if anyone else on my server had this problem; the two that spoke up were still able to see and use aforementioned recipes
• “Verify Files” function, via Epic Games store; I wasn’t notified of any problems, and nothing extra was downloaded
• reporting this privately; since this is apparently just a me-problem on the server, and I didn’t see anyone else with this problem when exploring the forums’ search function. Tried to submit a report through the Request Help function in-game, but naturally it’s disable for bug reports, right?


Installed Mods:

No mods, just apparently half-existent DLCs.


Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Step 1: Log in, I guess?
  2. Step 2: Notice many missing items from the DLC packs in benches, inventory
  3. Step 3: Also notice feats are still existent.
  4. Etc.
  5. Profit??

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.