Can't invite to clan. Bug or incompetence [SOLVED]

Game mode: [Online]
Problem: [Bug | Misc]
Region: [Here]

Hey, so the issue I’m running into is quite simple. A friend of mine was in my clan, he no longer is any longer but I did not kick him… I think… Anyways I can’t reinvite him as it only declines the invitation when he accepts it. Is there any way to rectify this issue or is it that he was kicked and there is a timer / permanent block on him rejoining.

Steps on how to reproduce issue:

Did he come back to clan as a new character. Check clan roster for information. I have kicked and invite back he part of another tribe

No he just all the sudden wasn’t in a clan, same character, no other tribe nothing his game just keeps denying if he accepts.

There is no timer on rejoining clan as people leave clan and rejoin all the time for testing purposes. Has he tried relog? Just a suggestion.

Yea he tried that too. It’s driving us nuts and no one has dealt with this yet.

We finally figured it out, still no clue what caused it initially but creating a new clan, and him leaving it fixed the issue. It was wierd and I’ll keep an eye out for how/if it happens again as this is super annoying despite having a super easy fix.

1 Like

be aware that if you leave your clan and there’s nobody left to reinvite you to it, you lose all access to all your buildings/storages and any items/thralls in them

I’m sure this isn’t directed at me specifically. I was still leader of the clan he was unable to join. He just made himself a new clan then left that to rejoin the initial clan. You are right though peeps gotta be careful otherwise stuuf could be lost

ignorance is bliss…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.