Cant log in to tru site into account

i got very old account done password recovery got it tryed log into game all works fine but when i try to log into account tru site it wont let me says wrong password thing im logging to new site login nothing helps dont know why it happening restored pasword numerous times waited half day to proccess nothing helps

If I remember right, the game account/password and the website account/password were always separate.

Also, the website password reset has been broken for years.

ok so i got the password and account name that work ingame only i want to get to master account that works in site to be able to buy premium etc and control my account how can i do that ?

If the password reset feature isn’t working for you on the account login page (, then the only option left is to contact Funcom support here: Funcom Help - Funcom

You may have to wait months for a response.

no that one where u linked worked and i got access to game but not to site when i try enter it to site it drops that Authentication failed, please check your password and try again i opened ticket already but no response so far and ty for helping

and i even created new acc that works properly thought to myself i gonna forget old coz u say it can take months and made premium but premium bugged and i got aproved paiment they took money from me and didint activated premium at all so for that i must wait months too ?

My guess is Funcom’s back end might still partially treat the game login and the account login separately. So the password reset might have worked for the game login side, but failed on the account side. All that I know of that you can do now is wait and hope your support ticket gets a response.

Yep. The premium payment system has been atrocious and some people never get their account properly flagged as paid, despite payments going through fine.

Funcom hasn’t cared for years, so these issues and insanely long support wait times have never been fixed.

I just started an Age of Conan Unchanged account, I can’t get into the server
I have requested a new Password more than twice, still can’t even log on with the Temp password…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.