Clan leader bugged?

I’m on official server 7071 pvp siptah
Clan Serenity
Problem : after passing clan leader to an other member we realized that nobody is clan leader, we can’t promote or demote each other Anymore…
Can’t recreate character, can’t leave the clan because it says we are both clan leader…

Please help


Thank you for your report. We’ll send this information over to our team for investigation.

In the meantime, have you tried recreating the character that’s stuck as leader?

We await your reply.

Yes i did try recreating the character, tried to leave the clan, demote or promote the other person and nothing works

Thank you for the additional information. Our team is aware of the clan leadership issue and will investigate it further.

@Mayra it’s been a week…any development?


Unfortunately, we don’t have any information we can share at the moment. Our team is still working on it.

Apologies for the inconvenience.

I have the same issue, the game thinks I am clan leader, but I do not have the clan leader symbol in the clan window. It will not let me leave clan, transfer, recreate character or make someone else clan leader. This is on server 1590 a PC server. I thought I would mention it here tho as this is one of the few thread I could find on the topic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.