Clan Leader Bug

I am clan leader on official server isle of siptah but it doesn’t show and i cant manage the clan!
i was promoted by the old clan leader
and i tried to leave the clan it says i am clan leader
but i cant give it to someone else!!!
on Playstation

1 Like

Good to see you figured it out.

i didnt

1 Like

I saw you checked solution. I have left as clan leader before but not in your situation. Perhaps someone else has experience it.

1 Like

Can you uncheck solution?

1 Like

i dont know how to uncheck solution i click on it there is still an arrow!

so , your clanleader gave you the leadership , and you tried to leave the clan while being the leader ?

then there was a message telling you that you couldn’t leave as a clan leader ?

then you lost the leadership ?

or did it happen differently ?

they gave me the clan leadership but the game doesnt see it!
i cant manage the clan cant kick players nobody can and i cant promote to 3 bars!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.