Coin piles deregistering, treasure falling through foundations

After server restart all coin piles and treasures I had were deregistered. The coin piles were still there and the treasure chests sank through the foundations. This happened on Aquilonian and Khitan foundations. I am now trying non-dlc foundations to see if that happens there as well


There does appear to be an issue with things despawning. Tickets have been logged already and I imagine Funcom are busy working to resolve the issues as fast as possible - many of their staff play the game too so there’s fully vested interest (for what that’s worth) :slight_smile:
(and very nice to see your balanced, non-screaming reporting of an issue)

1 Like

I’ve also had my treasure teleport from the 3rd floor to the ground. It doesn’t like to obey building pieces.

1 Like

Noticed that too on PS5.

I put the cat statue on the floor yesterday, and when logged back in today I didn’t find them. I checked the treasurer guy, and he didn’t registered any treasures in my treasury room. So I assumed it bugged, or that he melted the cat into gold bars?.. Then I obtained the lemurian statue and put it on the same floor. But when I returned to my base after another treasure hunting round, I discovered the Lemurian statue half way down through the floor tile. I removed the tiles and discovered both the Lemurian statue and the cat! They were standing on the barren ground. Naturaly the treasurer guy didn’t register them as they were technically outside the treasure room. I thought that the problem is in celling tiles, so I tried putting them on firm foundation, but they fell through it too… Interestingly enough, smaller treasures do not fall trough foundation, only heroic treasures. Lastly, I put all the heroic treasures on the tables. Will see if it works…

1 Like

let us know if that works, i already tried dlc and non- dlc fooundations

1 Like

Nope, didn’t work. They still fell through the furniture and foundations all the way to the ground.

This is beyond ridiculous.

1 Like

Same issue on PC server 6109. Treasures are falling through the foundations to the ground. Thankfully I only have 1 foundation before the ground but please fix these issues. Thanks!

Adding to the observed data, I did not encounter this issue when placing my treasures on a Turanian ceiling tile (my treasure room is upstairs).


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.