Coop Doesn't work

Played Conan some months ago with my GF. Wanted to pick it up again now with the new update. But like last time, I had to become a part-time PC engineer to get the game to work. I can’t be arsed this time so if you can’t help me I’m out for good.

Basic Info:

Platform: PC
Storefront: Steam
Issue Type: Other
Game Mode: Co-op
Server Type: PvE
Server Name: =SERVER NAME=
Mods: =MODS=


Bug Description:

Unable to join. “Attempting to join game” stays forever.


Bug Reproduction:

I got invited to join coop game. I accepted.

Greetings Zibnewski!
Thank you for reporting this situation regarding the Coop option not working.

In order for our team to properly assess the situation could you first give us the following information please:
1 - What are the specs of your PC?
2 - Is your internet connection WiFi or LAN?
3 - Are you perhaps using mods?

We’ll be waiting for your reply Zibnewski!

It does not matter what specs he have.
Your coop function just does not work. I will recommed you to check steam forums about this issue.
Many, many people bought Conan Exiles to play coop on steam sale and now they have to refund or just uninstall.
Sometimes it is possible to connect to your friends world but it is rare. Very, very rare. :melting_face:

1 Like

Gotcha, thanks for the reply. Like I suggested, I don’t want to put in hours of work with port forwarding and what not troubleshooting a game that’s supposed to just work. I’ve played tons of other games with coop functions and they work by just clicking on one single button.

@HighSaint

  1. Intel(R) Core™ i5-6600K CPU @ 3.50GHz, 20GB RAM, Windows 10 Home.
  2. We are connected to the same router with Ethernet cables.
  3. No, no mods. I got 1 DLC cosmetic pack and the Isle of Siptah DLC too.

Thank you for the requested details Zibnewski!

After consulting with our team, I suggest you to use the Steam option to ‘‘change accounts’’ in order for the system to force Steam to disconnect your account, and then please try to play online again.

Let us know if this solved the issue!

I actually just waited a couple of days and tried again, with no fixes and today it worked. If it doesn’t work in the following days I’ll be back. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.