Crafting Wont Work at Sanctuary of Mitra on Xbox

Game mode: [ Online official]
Type of issue: [ Bug ]
Server type: [ PvE-Conflict ]
Region: [ North America ]
Hardware: [ Xbox One ]

Bug Description:

A clear and concise description of what the bug is.

Expected Behavior:

I upgraded my Shrine of Mitra to the Sanctuary of Mitra. At the Sanctuary of Mitra I start the crafting process for items and the timer never moves.

Steps to Reproduce:

I built a Shrine of Mitra, then upgraded it to a Sanctuary of Mitra. I tried building a Statue of Refreshment and nothing happened. It started, but the time neve rmoved.

Hi @Tark and thank you for bringing this to our attention.

Can you please provide us with a screenshot of what you are seeing? We’ve upgraded your account permissions so you should be able to upload screenshots.

Also can you try to log out (while the item is being crafted), log back in and see if the timer is now progressing?

I tried logging out and back in and it still won’t work. Never starts the crafting timer it appears

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.