Decay System reset bug

Game mode: Online Private
Type of issue: Bug
Server type: All
Region: Europe

If you disable the decay timer from the beginning of a wipe, and enable it after awhile it only destroys the buildings that were being build after the decay timer was activated.

All other buildings before keep being time resetted.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Deactivate the Decay system
  2. Let players build their buildings
  3. Reactive the Decay System
  4. Check the Decay time on buildings before the Decay System was activated. It always resets.

Hey @LynX

Not sure we’re reading the report correctly, but it seems this is intended behavior. When you reenable the decay system, it will start counting from the value set in the server settings.

I do wonder sometimes if there’s a problem with the decay timers atm, am running a private server and the decay timers just don’t seem to want to tick down, have tried turning them off and on, changing the values even tho they’d worked perfectly fine for so long, and now recently I’ve noticed I run up to someones build to check the timer and it jumps up back to max :confused:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.