Dedicated Linux/Wine Server Performance Issues


It has been suggested on the steam forums I post that here:

I’ve just setup a dedicated server which is directly connected to an internet backbone. Playing with only 4-5 people on that that private server. It’s a mess. Even if I’m alone on the server the SERVER FPS will drop down to 3 (while latency goes up to around 500ms) at times.

It’s impossible to pinpoint the issue. I’ve tried all kinds of guides out there playing around with the server settings. Turning up all network speeds to 500000. Increasing server tick rate. Adjusting client settings as well (I can’t fathom why this should have any impact).

Normal ping to the server is around 13ms. So that can’t be the issue. One cpu core hangs around at 50% utilization. RAM is around 5GB (of 32 GB). No setting I try has any real impact on the performance. It’s almost as if it was limited artificially somehow. I can’t find the right “switch” and that’s left is this ominous (but maybe telling) error in the log:

Network:Warning: Data: BasePlayerChar_C_1 (server) received 3054.5 bytes per second > 1024 (sample window size: 2.00 seconds)
[2020.03.31-08.45.48:695][325]LogNet: UChannel::ReceivedSequencedBunch: Bunch.bClose == true. ChIndex == 0. Calling ConditionalCleanUp.

Maybe important: This is on a linux server using wine (following the wiki guide).

Hey there,

Could you provide the following, please?

  • A full server log.
  • Your device specs.

You can check yourself if your drivers are up-to-date. You should also verify your Steam files.

This is a generic issue. I believe more details are needed to know the origin.

Hardware Info (output of hwinfo --short)

Intel® Core™ i7-6700K CPU @ 4.00GHz, 1128 MHz
Intel® Core™ i7-6700K CPU @ 4.00GHz, 1093 MHz
Intel® Core™ i7-6700K CPU @ 4.00GHz, 944 MHz
Intel® Core™ i7-6700K CPU @ 4.00GHz, 1100 MHz
Intel® Core™ i7-6700K CPU @ 4.00GHz, 1128 MHz
Intel® Core™ i7-6700K CPU @ 4.00GHz, 975 MHz
Intel® Core™ i7-6700K CPU @ 4.00GHz, 1033 MHz
Intel® Core™ i7-6700K CPU @ 4.00GHz, 958 MHz
graphics card:
Intel HD Graphics 530
Intel 200 Series PCH HD Audio
Intel SATA Controller [RAID mode]
enp0s31f6 Intel Ethernet Connection (2) I219-V
network interface:
lo Loopback network interface
br-8e249f95ffe9 Ethernet network interface
enp0s31f6 Ethernet network interface
veth032b571 Ethernet network interface
vethfde2d1e Ethernet network interface
docker0 Ethernet network interface
tun0 Network Interface
/dev/sdb ST2000VX008-2E31
/dev/sdc WDC WD30EZRX-00M
/dev/sda ST2000VX008-2E31
/dev/sdb1 Partition
/dev/sdc1 Partition
/dev/sda1 Partition
usb controller:
Intel 200 Series/Z370 Chipset Family USB 3.0 xHCI Controller
Intel 200 Series PCH PCI Express Root Port #1
Intel 200 Series PCH LPC Controller (Z270)
Intel 200 Series PCH PCI Express Root Port #17
Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers
Intel 200 Series PCH PCI Express Root Port #9
Linux Foundation 2.0 root hub
Linux Foundation 3.0 root hub
Main Memory
DMA controller
Keyboard controller
PS/2 Controller
Intel 200 Series/Z370 Chipset Family Power Management Controller
Intel 200 Series PCH CSME HECI #1
Intel 200 Series PCH Thermal Subsystem
Intel 200 Series/Z370 Chipset Family SMBus Controller
/dev/ttyS0 16550A

Dedicated Server Log

1 Like

Thank you for the detailed information.

ConanSandbox:Warning: AConanPlayerController::Possess - Calling BattlEye::PlayerPossessed(this)

  • Try without BattlEye.

You did not see a BattlEye error pop-up or in-game message?

(on second thought, there’s a lot of errors in that log…)

Login:Display: [BaseGameMode_C_0] FindPlayerStart returns Translation: X=-50555.809 Y=321209.969 Z=-21130.000 Rotation: P=0.000000 Y=-85.786774 R=0.000000 Scale X=0.800 Y=0.700 Z=1.000

  1. Combat:Display: [BasePlayerChar_C_1] Start: -17873.080078 End-17851.701172 Fall Distance: -21.378906

  2. Combat:Display: [BasePlayerChar_C_1] Falling Velocity:-1449.056885 Percent of deadly fall velocity: 0.320755

  3. Combat:Display: [BasePlayerChar_C_1] Final fall damage:76.981178

You may have spawned / glitched under the mesh. Not sure.

Did you do any server restarts? (note, some settings only work after server restart)

I was wondering about the BattleEye entry myself. I didn’t activate BattleEye on the server nor did I install it on my local machine I play on.

Those messages are simply debug messages I think. I was just spawning on a ledge where I logged off last time. I then proceeded to climb further up and fell down. I think that’s what those messages are saying.

I turn off the server regularily. Just started it up for the log creation for example. I did’t bug under the mesh… at least not noticably. Maybe it registers as such if you clip a bit through the wall?

0047:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

The first error in the log, which also caught my eye. Try to (de- and re-)install the “winbind” Wine package.

The rest of the errors are ‘failed to execute file path’, for which I can only suggest to check that your files are in the right place; (C:)….…\ConanSandbox.exe\ConanSandbox.…

Thx for the hint… but how could they not be in the right path? I didn’t install the server by hand or anything. It’s all done through steamcmd.

Focus on the “windbind” package first, it should solve part of the issue.

I can’t say there’s anything wrong with the files as long as they’re generic pathing issues.

I’ve installed the winbind package to no avail… I’v also tried to setup a server locally via wine and that one is working just fine. I’m starting to suspect that there might be something wrong with the network connection to the backbone, not the setup itself.

Alright, I’ll ping @Toolguy to see if they can tell you anything about the issue.

I’ve found the reason and a workaround:

Disk I/O. More specifically mostly the writes to the Saved/ folder. The game somehow constantly (and in my opinion unecesssarily) updates the .db files in that directory. Probably to always have a recent safe file/backup in case of crashes or similar.

Workaround: Create a ram disk for that folder or get a fast ssd/nvm drive. With a ram disk you need to make sure to make backups of that folder every so often to aviod the loss of your progress. Funcom should have made most reads and writes in ram and only do (blocking) i/o every few minutes.

The question is why this problem gets worse with placables. You shouldn’t have to write the coordinates of static objects to a file constantly. Maybe it has to do with the items inside those buildings that will change due to crafting and decay. Even so… the i/o is way to agressive and could be toned down a lot. Losing a few minutes of gameplay shouldn’t be too terrible if it doesn’t happen all the time?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.