Dedicated server open ports but players cannot connect

Hello everyone,

I’ve been trying to run a dedicated server on my computer which i will also use for playing with a couple friends. The problem is: they can see the server on the server browser, but it appears as 9999 ping and when connecting it times out. I myself can connect to it, using my private IP address (192…) and the port 7779 (i changed it from 7777 to 7779 so i can also play the game on the same machine as i run the dedicated server).

I have downloaded and configured the server from here fun con official version 1-5-8 (Can’t paste links)

So, the things i have tried unsuccessfuly:

1 - i have put my machine on DMZ on my router network configuration;
2 - disabled windows firewall completely (and before that i had configured all the necessary port forwarding and aplication permission on the firewall, i decided to disable it completely to test if the problem was in there, but wasn’t);
3 - executed the dedicated server .exe as admin, both the first time so it downloads all the rest of the needed files, and after that as well (just running the server);
4 - i even used a higher port (30000) to see if my ISP was blocking the ports. But the problem persisted. I decided to confirm it by downloaded EGS (Empyrion Galactic Survival) dedicated server, to see if my ISP could still be blocking the ports, but it worked normally. I used a site (can’t paste the link, but its the “you get signal” one) to check if my port was open from the internet side, and when i run the EGS dedicated server, it appears as open, so, i tried the same port on Conan server, but the port was appearing as closed.

So i decided to check if Conan was really opening the ports correctly, then i used the program CurrPorts from NirSoft to monitor the application ports, and it saw that it opens a UDP port on 7779, but not a tcp one. So when i check if the port was open from the site i described above, it looks closed. The curious thing is: when i login using the local IP and the port 7779, it creates temporarily a 7779 TCP that the site recognizes as the port is open, after a while, the tcp connection on the 7779 port is closed ( i guess that its when the game finished loading my character) and the site says that the port is closed again.

I’m completely lost in this matter now, and i would really appreciate any light you guys could shed in this situation. English is not my mother language, so i tried my best to explain the situation, if i did not made the situation clear let me know, i’ll try to explain better.

PS: Oh, yeah, the three lights for testing the game availability (Game client port, raw udp port and source query port) all checks out correctly when i click “Test Port Accessibility” button.

Thanks in advance.

Stay safe.

Did you check the multihome box? I believe you need to if playing on the same machine as the host server.

Hello Darthphysicist, thanks for the reply.

Yes i tried with and without that check. Did not work :frowning:

So try this even though it sounds weird. Put the first port at like 1000 and assign the last two to 1002 and 1003 (the second one of course will default to 1001). I had a router that just did not like my two servers being close together in port number once… don’t ask me why; I never figured it out. It just hated it…

Oh ok, you mean changing Game Client Port to 1000, Raw UDP port 1002 and Source Query Port to 1003?
Because if thats the case, the server software does not allow me to manually change the Raw UDP Port, its always the Game Client Port +1. Tried to check on the file “Engine.ini” at the folder “E:\Games\Conan Exiles\Season2\DedicatedServerLauncher\ConanExilesDedicatedServer\ConanSandbox\Saved\Config\WindowsServer”. Any idea on how to do that port trick you said?

No set them to 1000, 1001 (forced like you mention) 1002 and 1003 down the list.

Ohh right, you were clear at the first suggestion, i just did not understand.

Well, i just tried those ports configs, and the issue persists. I’m not sure about this, but, the ports on conan are not on the state “listening”, shouldn’t the game port be on that state?

Do you have it configured for both tcp/udp?

Where do i check that configuration? On conan server software? Or do you mean the configuration on my firewall/router?

When i run the server, and check the ports on the CurrPorts program, only shows the ports like this:
Process name | Process ID | Protocol | Local port | State
ConanSandboxServer-Win64-Test.exe 22364 UDP 1000
ConanSandboxServer-Win64-Test.exe 22364 TCP 61384 Established
ConanSandboxServer-Win64-Test.exe 22364 UDP 1001
ConanSandboxServer-Win64-Test.exe 22364 UDP 1002
ConanSandboxServer-Win64-Test.exe 22364 UDP 14001

You configure it on your router/at your isp. If I’m not mistaken your ports are a bit mucked up. Are you using the dedi launcher? I have never configured a server without it, but the four ports in order should be tcp/udp, udp, udp, tcp. On the dedi launcher it would end up like this:

With 100X in your case. It looks like your ports arent configured right on your router.

1 Like

Well, this is the first time i’m using this dedi launcher, and what i see different on your picture is that all five lights are on, first four are green and the last one red, on mine it only appear the first three green, then the other ones are just off, not green neither red.

I have put my computer on DMZ on the router, for i was told this makes all port forwarding available.
Additionally I added manually all theese ports im currently using (1001, 1002, 1003 and 1004) on the firewall and port forwarding of the router, just to make sure that the connection will pass through. Also, i executed the dedicated server for another game (empyrion), to see if it would be able to open the connection port for the other players, and it worked just as i expected. Also the test to check if the proper port (i used the 30000) was open, and it succeeded. Then i tried the same ports on conan, and differently, conan opened the 30000 only in udp, not TCP on listen mode as the other game laucher did, this raised my doubts about the proper permission on the conan dedi lacunher, so i tried to execute it in admin mode to check but the problem was still there.

When you execute your dedi launcher, does it open UDP and TCP port for the game client port (3000 in your case)? I think you can check that with the command “netstat -ano”.

Yes 3000 is configured for both tcp and udp, which is needed. I suspect thats your issue. The fifth being red for me is a recent problem but the game works just fine… I gave up on that one! :wink:

Oh thats an important information, thank you so much!

I’ll investigate why my dedi server is not opening the game port on TCP like it does with the UDP. Btw, what version of the dedi server are you running?

I’m using 1.5.8.

Good evening,

So, i have tried some network modifications here and even running the dedi server on another clean machine but the situation is the same, the server is not opening a listening tcp port for the game client port, regardless of what port i use.

So i’m giving up on this one guys. Thank you so much for the help @darthphysicist, this was my first experience in online forum and it was very positive.

If i ever meet a solution in the future i’ll post here.

Take care and be safe


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.