Dedicated Server Tool - Issues - Rcon, Restart Announcements, and Discord

Rcon:

  • Enter all details, click save, click restart, all details and data cleared, no Rcon access. I googled for a day and found that to activate Rcon you have to add the launch parameters for it, so what’s the point of the Rcon data entry fields then?

Restart Announcements:

  • Literally, there isn’t much else to describe other than what is happening HERE which is exactly a year old now.

Discord Webhook:

  • Not gonna lie, Webhooks are a part of Discord that I had never really messed with or completely understood until now. Fairly simple and easy to setup honestly. But… they don’t work on the app. They work flawlessly through the Pippi mod, and that’s where i learned how to set up Webhooks, oh my god, it was adorably easy.

Now, the one and only server I have ever hosted that refused same gateway connections, and now the settings don’t save OR, they aren’t supported? Not entirely sure, as the Discord integration doesn’t do anything, Rcon data doesn’t stay after restarts, and it’s been live for days now and not once did it offer a warning to restarting.

Updates:

  • Rcon: After some digging I found “Game.INI” containing the Rcon settings and configured it manually as I usually do with almost every other server i’ve hosted. I can confirm that CEDSL resets that file’s Rcon settings for whatever reason.

  • Restart Announcements: Tried manually adjusting the settings in the “ServerSettings.INI” file. I removed the quotation marks on either end of the messages, I feared that might have something to do with it, but that remains unchanged. Still no messages… WAIT, surely it isn’t MM:SS timing format? IS IT?! omfg I’m about to scream. Will update after testing…

  • Discord Webhook: Resolved, honestly not sure how.

On a side note, I did manage to resolve my multi adapter configuration issue. Even though the setting in CEDSL was disabled, and “Engine.INI - DedicatedServerLauncherMultihomeEnabled=False” the config and/or CEDSL still had the Local IP, “DedicatedServerLauncherMultihomeIP=192.168.1.36” This had locked the device I wanted to use with the IP 100.100.100.10 (my ASUS XG-C100F) from communicating with the server at all.

Update:

  • Rcon: Still unresolved.
  • Restart Announcements: setting format is HH:MM as it states in the Popup. Still no change in game for announcements. Though it does share them to the Discord webhook now.