Disconnect crash


#1

So since 1-2 patch up patches for the agent system down I have some weird crashing issues where the game disconnect and crashes when attempting the reconnect. Since I had a move inbetween I am not that sure if it isn’t connected to my hardwar as I did obviously change internet connection with the move.

Anyone else having the same issue? Just so I know if it’s an issue among people or only for me.


A stream of lost connections
#2

I had similar crash on reconnect issues. The only “new” things I had in my configuration were the mods ClockWatcher and AgentTweaks. I removed these mods and the crash issues were resolved.


#3

I don’t have AgentTweaks but I have Clockwatcher. I will try removing it. Could be an issue with the new version 1.2 that came out.


#4

I have AgentTweaks and I have not had any crashes. I haven’t tried ClockWatcher, so that sounds like a likely culprit.


#5

Thanks for the heads up on this Leogrim. I’ve identified an issue in Clockwatcher 1.2 that seems to be the culprit. Accessing the agent API while not connected to the server does not fail politely.

If it’s a serious issue at the moment, disabling the offline viewer data dump (/setoption efdClockwatcherOfflineExport false) should fix it (with the obvious consequence of making the viewer useless). I’m working on a solution at the moment which should make it into the next release.


#6

Reinstalled and used this option. I am crash free again. :smile:


#7

Just had that happen and I don’t have either of the two addons listed in this thread. First time with this flavor of d/c!


#8

Twice today I got disconnected as the interlude between waves in a scenario ended and then the game crashed when I clicked yes to reconnect to a new server.

Edit:

I’ve tried using this and every time I log in it resets to true.


#9

Hmm. I thought the issue I was having with that one was transient on internal builds of mine. Since the other bug I’m tracking down seems to only affect me, I’ll see if I can clean up my test code and sort out a release with the main patch when I get back to my computer.


#10

Should be fixed as of v1.2.1. Thanks again for the report, is much easier to remove bugs when I know about them.


#11

new version running nicely. Thanks!