Agent Access Crash to Desktop


#1

When I access my agents menu using the ‘P’ hotkey or clicking on the agents icon for the first time of the day it will crash to desktop consistently.


#2

I think this is a known issue, but if it helps, I had the crash to desktop three times in a row before it worked for me, but then it worked a few times afterwards. So it can happen more than once, but maybe once it’s fixed once the problem goes away.


#3

it’s been happening to me too, like 5 times this afternoon. I tried repairing twice and nothing works :frowning:


#4

I’ve had the Hit-P-Crash multiple times on both my subbed main and F2P alt. So far it has mostly worked for me to hit the Agent icon up by the SP counter on the upper right, although generally I only remember to do that after I have hit P, crashed, and re-loaded.

Using P has also worked a couple times when I went to SC or BM, did a side or two and a main or two, and then hit P.

But mostly it crashes.

Edit: Just went back in and looked now… after cashing in the previous Agent mission and starting a new one, the Agent icon in the upper right (beside SP counter) is gone. So I am surmising that that icon only appears to say “You have completed agent missions”, and I further surmise that it is hitting P while that icon is visible that is crashing.

Will need further testing, but in the meantime, if an agent mission is complete and you have the icon up by the SP counter, try hitting that instead of P.


#5

The first time I hit the icon while it was an icon, the game crashed so I’ve been sticking to P. I think either way it crashes.


#6

We are aware of the issue and will be looking into making adjustments to help alleviate client crashes. We believe it’s connected to Scaleform and intermittent crashes it suffers from when trying to draw too much on the screen at once.

For now we suggest avoiding UI mods that draw tons of stuff on the screen and keeping the number of other open menus at a minimum when accessing the Agent UI.


#7

@andyb it behaves exactly the same as the skill window did the first month or two.

Causing random crashes, more often if 4GB patch is not applied, more often in heavy zones (Tokyo, Hell dungs) and it crashes much more often if opened just after login/zone change.

Maybe the same fix will help here.


#8

Thanks for the heads up Andy. Glad you all are working on it <3


#9

Just a note:

Today, tried my ‘click the Agent Icon in upper right’ theory on first load-in of the day. Still crashed, so that notion is kaput.

It does seem to happen the most on the first Agent window opening of the day, will test some more.

Edit: just restarted, log in to Agartha, hit the Agent Icon in upper right, window opened fine.

@Andyb: my own version of SWL has no mods, no changes to base install, medium graphics settings, and nothing but the chat window was open when I clicked the Agent icon, which is also normally the case when I hit P. However so far I have been in Agartha (most times) or London post office (twice) when it crashed.


#10

This is my suspicion as well. Unfortunately there’s a bug deep in the scaleform middleware that we use for our UI where it seems to just be losing track of UI elements if too much is going on at once. Since we’ve gotten an actual artist for the UI and it’s not just me drawing gray boxes anymore, our UIs have become both more visually appealing and less likely to play nicely with this scaleform bug.

The particularly frustrating part is that this rarely shows up for us internally on our work or home machines, so we basically have to fix it almost completely blind. I will be going through the Agent Network UI today and flattening and simplifying where I can while avoiding any changes that would be visible to you guys. So hopefully soon we’ll get a version out that doesn’t cause any issues. Obviously we’ll need your feedback to let us know if the problem is resolved, so be on the lookout for a patch note about it and let us know if you have more issues after that.


#11

No Mods in use, , repaired client, totally new installation, tried running as admin…
yesterday 7 crashes at trying to click p or the agent icon, then it worked on all 3 toons . but today again crashes


#12

All right, so, I’ve been gathering advice on side-stepping this crash for the past couple days. This morning, I put it all together.

-Zoned into Agartha, moved out to the bar, faced into the side of tree so virtually nothing except some bark was on screen.
-Did a /reloadui to reset the UI.
-Hit Ctrl-Z to remove all UI interface elements… thus, virtually nothing was on my screen.

Hit P. No Crash. Also, no agent window because UI is turned off. :slight_smile:
Hit Ctrl-Z to turn UI back on. Agent window is up and available. Accept mission turn-in, poof it works!
And the Agent who has been stuck at level 1 for 3 days because P crashes each day… hits level 3!

May refine this process over the next couple days to see the minimum approach to avoiding the crash.

TY all for the info and advice posts!


#13

I experienced my first agent crash just now.
I had some spare aurum, so i went to the agent window to buy a few booster packs. Closed the agent window, opened the bags, and pressed P to reopen the window. Then it crashed.

I’m in Agartha.
I have 3 mission slots occupied.
I have 5 agents in total.


#14

have the same issue, but not only with agent interface. after last patch I have frequently game crash to desktop doing lair/WB/dungeons. very frequently.


#15

An update, for both the crash problem and the not-getting-agent-XP problem:

For the crashing problem, this has worked for the past 2 days:
-Log in, move to face a wall so very little scenery in front of me. Hit Ctrl-Z to turn off UI. Hit P. Ctrl-Z to turn UI back on and my Agent window is open, no crash.

For the experience problem, this has worked currently for 9 mission turn-ins:
-Click on the Agent head icon first (since I only have the recruit, it is always the agent who has a mission complete). Then click the mission button, then hit Accept. This has netted proper XP in each case.


#16

Sadly facing a wall didn’t work for me . Had no issues this morning, but when I tried the last hour I had 5 crashes in a row. I walked around, did a quest and then faced wall, hit icon crash :((


#17

Yes I probably should have mentioned, facing into a wall to reduce screen clutter didn’t work by itself for me either. That is what the Ctrl-Z to remove the UI elements was for. I suspect that is the key part. Not sure if it works for other people but it’s worked 100% for me (10 non-crashes after first log-in).


#18

Today I tried doing /reloadui after the Login Rewards popup before opening agent and that worked, knock on wood.


#19

first try after hotfix/update. Finished a mission, upgraded some talismans and tried to
open agentwindow…crash


#20

Still crashing after fix. So much for that.