DLCs locked from a Steam family shared alt-account

Game mode: [ Select one: (Online private)]
Type of issue: [ Select one: Other ]
Server type: [ Select one: PvE ]
Region: [ EU ]
Mods?: [ Are mods installed: No ]


Bug Description:

A clear and concise description of what the bug is.

After the last update, after linking the second account to the twitch profile (or at least trying to), my family-shared alt account (made due to the limitations in building pieces per character on our server) suddenly appears to have lost the enablement of some of the DLCs, including Siptah.

Expected Behavior:

Same list of enabled DLCs like on main account:

Instead, the alt-account has this:


Installed Mods:

All deactivated, server uses no mods./


Steps to Reproduce:

Dunno, have a family shared account that broke down?

I’d be glad if anyone knows if it’s a problem with steam, funcom launcher or what - just wanted to watch streams to unlock the feats on both accounts, really…

Each account in the family has to own a copy of the game and any DLC they want to use if you are on official
https://forums.funcom.com/t/changes-to-steam-family-sharing-settings-on-pc-official-servers-with-update-2-1/144074

Nope, it’s a private server - and until yesterday evening, it worked just fine. It seems like it got broken due to the “free week” - is it possible that Siptah and those DLCs that are shown as “not owned” are simply not part of / disabled for the free week?

Admin may have turned family share off

@Keltica Thank you for your input, but it seems rather unlikely - though I’ll be sure to ask him. However, wouldn’t you agree that due to the fact that I’m:

#1 able to log onto the classic map
#2 have about 70% of the DLCs enabled

it seems rather strange to assume that the reason of missing those specific 3 DLCs is due to the Family Sharing option having been disabled? It’d seem more logical to assume that - if that were the case - I’d just be unable to log into the game at all, wouldn’t you agree?

I am sorry, do I understand right?

  1. You have a main account A that has all DLCs and you linked it to twitch account X.
  2. You linked family shared account B (which doesn’t own the game) to the same twitch account X which caused some DLCs to not be available?

Probably not. At this moment I’d suspect that the “free week” setting is overriding the family sharing ones, as previously, after a reboot - I always had to request myself on the alt account to “borrow” the game. Now it’s displaying just the standard green “Play” button, but missing 3 of the DLCs.

@Narelle do you know, by any chance, if Siptah DLC is excluded from the freebie week?

The free weekend is only for the base game/map but for the kill event mobs will count. Not sure what you mean by freebie week.

I though that the free access/demo/trial was announced as a “free week”, instead of just a weekend? That’s what I meant with the “freebie” - as in, you can access the game for free during that time.

I tried the twitch drops yesterday, with main account.
My steam was linked to twitch since long, but i had to delete the link, relink it again, to make it work properly.
Not even tried family share right now.

Also browser may impact, Firefox makes troubles with Twitch, Chrome is working for me.
So may be bit test and trials to get the stuff. :wink:

Sorry, you are right. Usually it is a weekend only, this time is a week though.

Same thing is happening to me i can’t play on my alt account :frowning:

Had a similar thing happen after deleting the steam cache.
Had to log into owner account and validate the game. It’s worth a try I suppose.

What do you mean “validate”?

Check game-files trough Steam.
Go on your library, right click game, property, there you find the option to check your game-files. Can happen that a file is broken or corrupted after a patch. So still good to make some verification in case of troubles.

I couldn’t launch game on alt because it couldn’t verify ownership of DLC. Went into owner account and verified game files and then it worked. While you are doing that steam says ‘validating’ in library.

1 Like

Could we fix this please still not working any word on why its not?

I have now checked this as well on my account. My main account has all DLCs and I have linked my main account to Twitch (if this makes any difference). When I log with my family shared account, I am missing the same 3 DLCs as in the opening post:

In my family shared steam account, I also see only 10 DLCs:

image

1 Like

That’s strange, i did the test, but they show all up for me.
Like yours, my main-account is also linked to Twitch.

Steam, region related ?

I doubt because my region is set to Germany which I believe is yours as well.