Siptah DLC not accessible in Steam Offline Mode

Basic Info:

Platform: Steam
Issue Type: Other
Game Mode: Single Player
Server Type: =SERVER TYPE=
Map: Isle of Siptah
Server Name: =SERVER NAME=
Mods: =MODS=

Bug Description:

Siptah DLC not accessible in Steam Offline Mode

Bug Reproduction:

Put Steam into offline mode, start game on Siptah map.

This has already been reported in Sept. 22 and nothing has happened so far. The “public” bug tracker is also not available publicly but private so I cannot check if this is even being worked on. This is important! I paid money for something I cannot use!

Greetings Exile,

Thank you for reaching out to us.

  1. Try the “Change accounts” option while still online and re-log into your account.
  2. While still online please check your DLCs to see if Siptah is active:
  3. Steam Library > right click Conan Exiles > Properties > DLC
  4. After performing these steps, please join the game on an online server and leave. This will ensure you have all the latest updates from Steam and from our end.

Please let us know if the issue still persists in the offline mode afterward.

i have the same problem i cannot play siptah offline , but normal map is avaible and i can play offline , this start after sorcerery update was introduce and not fixed until now , online all workss but once i enter offline mode steam i can only play base map and dlc i need unlock evry time i log again , when loading siptah its say that i dont have dlc .

Hello Mayra. Thank you for your assistance. I followed all the suggested steps. Unfortunately the game still shows the same behaviour.

Going by the pictures I believe you own the Siptah DLC but don’t have it installed for some reason. Or the game is not recognizing it as installed.
On the second picture look how Siptah showing the dlc size but all others aren’t (that might have something to do with your problem).
I had the same issue but don’t remember how I fixed it, might need to reinstall (or check game integrity?).

Hey, thanks for your input. All the DLC items that come with Siptah I can use. Only the Siptah map I cannot load while offline.

  • I tried unchecking the DLC and let Steam remove the files
  • then restarted Steam
  • and installed the DLC
  • then restarted Steam again
  • and verified files
  • then started Steam yet again
  • and started Siptah online
  • then went into offline mode and tried to load Siptah.

I got the same error message.

They will not fix it , they dont care , its almost half year and its still the same .

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.