Account claims to not own Siptah

Game mode: Single-player
Type of issue: Bug
Server type: PvE
Region: America
Mods?: No
Edition: Steam


Bug Description:

Bought Siptah on Steam about a year ago. Used it fine back then. Now the launcher claims I do not own Siptah and I cannot craft Siptah items such as rhino saddles. Steam still says I own it and warns buying it again will not add the item to my library.


Steps to Reproduce:

  1. Launch the Launcher.

On steam, have you checked to be sure Siptah is ticked under the Manage DLC’s window?

1 Like

As droch-aon said, please make sure that the DLC is enabled through Steam before going into the game. Let us know if that helps.

Double check and yes, all DLC, including Siptah, is checked already.

Anyone know anything else I could try? I really want to play Siptah!

Hey there, as you already checked the DLC status in the Library, it might be a good idea to reach Steam Support about it. Let us know if it helps.

I tried using steam support and it just tells me to go back to funcom. Requesting a steam refund of siptah DLC. If they refund the game, I can buy it again and it may fix the account issue. Assuming they process the refund.

I am having the same issue. Everything is ticked. I play Conan using GeForce Now.

I play Conan through Steam on Geforce Now. When I checked for Siptah on Steam directly the box was ticked in. But when I checked Steam in Geforce Now it wasn’t ticked in. After ticking in the box it worked again. So that might be your problem if you play through a cloud service.

1 Like

This was the problem! Thank you so much, okodi!