Downloaded the Patch but I see no Changes. (PC) (Solved)

Hello, Me and my friends all have the same Issue, We have downloaded the Patch but when we start the game nothing new is added or so, I Downloaded a patch that was 11GB but nothing is showing in game. Not on any server and not even if i start a new Singel player game.

I tried to verify the files in Steam but nothing happened.

EDIT: Solved, or well. There never was any issue in the first place. :slight_smile:

You wont see the changings in the beginners area. Exploring the map further and getting higher up in levels you will see the changings to the major settlements. Also there is a new dungeon. The entry is in the swamp biome. Its not very obvious :innocent:.

But I can’t even see any new Feat. Witch doctor for example. If I search for the Feat I can’t find it?

Or is it one of these that you can only see if you have unlocked it by some criteria?

First question always asked do you or the server run any mods. If not you may have to do a full clean reinstall.

We had a mod but that mod is removed, now I’ve uninstalled the entire game and just about to start it again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.