Excessive Player Damage Output

Platform: Steam
Issue Type: Gameplay
Game Mode: Co-op
Server Type: PvE
Map: Exiled Lands
Server Name: none
Mods: Warrior Mutator is the only ‘balance’ mod I use

Starting a fresh save and noticed at random that my damage output will jump to around 10x the intended output. I have messed with server settings by dragging the sliders up and down to see if this fixes the issue to no avail. The only solution I’ve seen (which is not a solution) is lowering the Player Damage slider down to compensate. I should not be doing 50 dmg with stone daggers or 90 with a wooden bow and flint arrows, it’s incredibly annoying. Never had this issue until 3.0.

I have tried hard to reproduce the bug to no avail.

I would like to follow up a bit on this after trying to reproduce the bug itself. Starting yet another fresh save, I only ever tampered with the server settings once and that was for crafting speed. After every level I made, I would test the results based on which attribute point was given where, just to see if that had any factor to it. So, eventually, I reached level 13 with a third point placed into Grit and that was when the game decided "Okay, it’s time for you to do 90+ damage with a wooden bow/flint arrows and 100+ damage with a stone two-hander.
I am also leaving out the fact that the game has locked up twice in the few hours I was testing.
I can’t remember the last time the game has been more broken than with 3.0. It’s a bummer, but the game is simply unplayable as is.

Greetings DeathKnell!
Thank you very much for reporting your situation regarding the excessive damage output.

Very detailed explanation DeathKnell! Have you perhaps tried to reproduce it without the mods installed?

I know this is a bit late, but after a bit of extensive mod testing, I estimated that it was Apollonia’s “Emotes For Thralls” doing the issue (weird as that may seem). They tested and found that was to be the case and fixed the issue.
Thanks for responding, regardless, just glad that issue was resolved.