Expired AMD driver


#1

Trying to return to the game after some pause Meanwhile changed my GFX card from Nvidia to ATI and Im geting the message “You apear to be using an outdated video driver” My graphic card is AMD Radeon R9 200 / HD 7900 series and my installed drivers are the latest ones. I tried to ignore the message but game its unplayable my fps going from 30 - 0 freezing avery few sec for 1-2 sec. Tried to play on DX 9 not helping. Any fix to this problem?


#2

Starfox posted a fix in an earlier thread.


#3

Not sure if anyone has gotten it to work though.
Shame i threw away all my old AMD cards, otherwise i could test it more.


#4

I must be doing something wrong coz its not working


#6

Hello, I’m sorry to hear that you’re having difficulties running Secret World Legends with your new video card!

Could you please verify whether you uninstalled your old NVidia drivers properly? Feel free to use the following link for assistance:

http://www.nvidia.com/object/IO_13955.html

Please leave a response if you need further assistance after checking this!


#7

It will also help if you are able to provide the exact model of your graphic card. There is a few different cards within the R9 200 series ^^

Alot of AMD users gets that message (has gotten since TSW), but none of the peeps that I personally know has any major FPS issues. Hence I asked if you are able to tell us the exact model of your card =)


#8

Strange but after a few switching from dx9 to dx11 and back the problem is gone. Fps its still not great, its around 20-25 but at least game its playable. The graphic card model its: XFX AMD Radeon HD 7970 Black Edition 3GB GDDR5


#9

I’m glad to hear that you’ve managed to get SWL into a playable state! If you would like to follow through on uninstalling the NVidia drivers or contacting us at funcom.com/help for further tech support, please feel free to do so. We’ll be happy to see if we can’t improve your in-game performance.


#10

@Starfox I tried to edit prefs_3.xml but doesn’t work. Maybe a problem with the new numerological format of AMD’s drivers, which is not xx.x but. xx.■■■.xxxx ?


#11

I have an AMD based desktop computer (the graphic card is an AMD Radeon R9 200 too).
I’ve got the same message as you, but I don’t remember, that I’ve had FPS issues. The game runs with normal FPS, the only thing, that very rarely the game crashes. But this is not a big problem (ok, in a dungeon still big problem…:smiley:)


#12

And here we are today still with no fix to this. I just installed my new RX580 8gb with current drivers ( and yes, all other drivers cleanl uninstalled, so you can skip that excuse ) and got the same “outdated driver” warning and the game runs with constant stuttering in dx11.

Hey Funcom, remember that you do indeed have other games and either fix or remove your “driver identification” system? Thanks.


#13

#14

Thanks for the feedback everyone. I’m closing this thread as it’s not active enough to need ressurecting and passing the feedback on appropriately. Thanks again.