Explore the entire Exiles

Can someone tell me if this journey can be finished without admin stuff? I can’t seem to find a solid answer anywhere (or certainly not up to date)… I’ve gone over every interactive map I can find, and I seem to have them all, but i’ll keep checking if someone can tell me that this can be done without teleporting to some off map site.

1 Like

Hi @Me.Greedy and welcome.

What I can say you is my personal experience with this journey step.

When I first tryed to complete it, without any success, peoples on the server where I play said it was known it was bugged.

Than one day a guy completed it saying “it’s fixed, but you have to discover a new location to trigger it again”, so I was totally unable to test it without any admin commands (I already had all of them and I was playing on an official server).

I don’t know the current state of it, if now it works or not, I completed (meaning I found all markers of the map) months ago.

Some of the posts I’ve read about this claim that the spot where the game’s intro movie takes place counts as one of the locations, but that it is not reachable save by the use of admin commands or mods. What I can tell you is, this past week I made a point of visiting the last few map locations I didn’t yet have (as noted on http://snowhawkclan.org/map/ ) and that journey step did NOT complete. I was…

FWIW, this is on an Official PvE.


This is due to one or two unmarked locations beyond the Cursewall.
The one we think is the culprit is an easter egg (so let’s leave that for now).


Hey, you’re supposed to use the spoiler text to explain what the spoiler is, not the fact that there is one! That’s just cruel and unusual punishment. :stuck_out_tongue:

1 Like

But then people would often just click or hover over the spoiler to see, or accidentally see what’s inside :fearful:

Here you are then:

Edit: we removed the second option, “Non”, from the wiki. We concluded it to be a troll post.


I was already aware of those supposed locations, which is what I was alluding to in my earlier posts. However, I wasn’t able to trigger either even in admin mode with god status enabled (still die at the curse wall, and can’t teleport past it).

Unless those actually open in the dev kit, I’m inclined to think “Non” may be a troll post.

Did you “beat the game”? Because if you have ALL the locations AND you “beat the game” that’s the final “location”
Beating the Game:
collect all the artifacts, got to the chaosmouth crafting atation, fight the boss, create the keystone, GTFO of dodge.

It is possible to reach the trailer location via admin with no need of God mode. It is actually possible to go to any location outside the ghost wall. The problem is, the ghost wall appears visual to be one walls width. When infact there is an invisible death zone of 20 foundations deep. :wink:

1 Like

Well, won’t do me much good on the Official I play on at any rate. :rofl::sweat_smile::thinking::unamused::cold_sweat::sob:

Have you let several people test that? I’ve heard noone coming back saying this yet.

Apologies, to which post are you reffering?


No but that’s what worked for me and my girl

You can click this bit here to see
I’m refering to the last location being when you finish the game.

Yea never knew that I could click that. Lol

Thanks for the reply :slight_smile:

Of course.

We were running around for days frustrated a. The op, we googled and wikid and tried everything and realized we hadn’t tried EVERYTHINGso we beat the game

Good to know, but I don’t feel like having to juggle clan ownership and restart on a new character (wherein all the journey steps will be blank), just to complete one that I won’t be able to appreciate. Gonna chalk this up as another intentional troll on the devs part. :joy:

1 Like

Yea we we’re more pissed off at the seriously ridiculously unimaginative lackluster endgame cutscenes

As it was our first time beating the game

1 Like

Like… Seriously?? That’s it? We were expecting way more than I’m just gonna casually walk out this ghost fence now … And cut to black, new character menu pops up like wtf