Journey Chapter X, quest 6

Good day. How to get through the journey “10.6 Explore the entire Exiled Lands”. I opened all the ruins of the camp, cave, lore tables, emotions, location according to all known maps. But still something is missing. I will be glad to see a screenshot of the full map or a detailed list of all types of adventures.

Last I heard, that journey step is bugged. There is a location in the southwest that is outside the boundary of the map. The only way to reach it is to use Admin Panel in SP.

3 Likes

I think you get that visited, if you “leave the exiles land” (using the artifacts to remove your wristband).

1 Like

I didnt know that…@Maedhros what is the name of that location?

I can’t check now, but I found this post that might give the correct coords. If that location is still accurate.

1 Like

In solo mode, I was able to use the teleport to this location and got a point on the map. How to do it on the official server? I think this problem is not one day and it is not clear why it is not solved.

1 Like

Wow interesting. I will give it a try when I get back to work on that step. It is one of only 3 steps which I am yet to complete. This one is purely because of time constraints.

Please try this one first: Explore the entire Exiles (what I said in 2nd reply…)

No I have not done that one yet jot29, and to be honest, it is the one Journey Step which I will probably never complete. As an Offline Singleplayer, and hence a one man workforce, it took me well over 6 months to grind out a two storey T3 (Black Ice) mansion. I dont have the manhours to go through that again. Ill just try to Admin teleport to it.

PC users can type out teleport Cords and nab it, Console user can only teleport via clicking map and hoping they don’t land on invisible kill zone down there.

No Tidle ~ key or keyboard support for that. =/

I’ve tried a few times, getting outside map is pretty much instant death. I’ve been teleported above locations via bad load screens, but sadly can never get Fill maps or Mummy of Set done.

One day…one day.

To teleport behind the wall, you need to enable the ghost mode (noclip) in the admin panel. But it still does not work on official servers.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.