A little help? Explore the entire Exiled Lands

SPOILERS BELOW!!**

Brother Exiles I need a spot of help. After a long hiatus and much time investment I finally got around to completing one of my only three remaining Journey Steps. I am refering to ‘Chapter 10: Step 8. Explore the entire Exiled Lands’. And when I say completed it, I mean that provisionally. Following the Snowhawk Clan map, as far as I can tell I have found ALL of the required locations, however the Journey Step in question did not pop/log as completed. Does anyone have any ideas, or know if perhaps Snowhawk Clan map is missing any locations…?

Now before posting here, I remembered a number of members discussing this in the past, and reading that there are a number of locations outside of the Cursed Wall. The first is the Trailer Scene location, the second is called ‘nom’ if I remember correctly, and the third is the spot where our character walks through the Cursed Wall after removing the Bracelet. I have been to the first, but am not sure where to find the other two. Can anyone else help me out with this problem?

@jot29 I know you were knowledgeable on this matter in past threads. Any advice? And @Shadoza I kbow that you have Escaped the Exiled Lands numerous times. Do you know whereabouts on the map that this cutscene location is/takes place? I welcome any answers and takers on this issue. Someone please…a little help…?

Sources:

Do you see the two dungeon entrances to the volcano (“The Floe”,“The High Way”)?
Sometimes there is an issue. Even after discovering them, they won’t show up on the map and you won’t be able to finish the journey step.
After searching on the Internet, I went back there, walked REALLY slow in a straight line towards the middle of the cave entrance.
Then both locations showed up on the map.

Hope this helps.

1 Like

For this 2, you have to kinda climb around the cave entrances…

@Croms_Faithful there is 1 fix method where you need admin rights and teleport to the location and the other one is, that you finish the game and while you do that you visit the last waypoint.

But this finishing the game is based on 1-2 people who said that. Never actually did it myself, as I am still missing some waypoints (but not The Floe or The Highway).

Also did you get all starting way points? There are 5-6.

2 Likes

Thankyou for the reply Ch_Ru. I know for certain that I have found ‘The High Way’. For ‘The Floe’ while I am fairly certain that I have, I cannot say with absolute certainty. I will check after I finish work today and report back in.

Thankyou for the reply jot29. As a completionist at heart, I am determined to complete this step.

Ahh no problem at all jot29. I am a purely Offline Singleplayer, so I have full access to Admin rights. In fact I have spent a good bit of time wandering around outside the Cursed Wall (I call it ‘The Outer Rim’).

So what is the fix, or where can I find the last waypoint which you mention here?

I did my friend. I was sure to get them all when I Discovered all of the Giant-King Obelisks. I used the Snowhawk Clan map and went from grid square to grid square, one at a time.

I am also wondering if @TwoJay and @TheLOLxd2 have any advice on this matter?

Forgive, I do not know where the location is. I do know that there are two fence posts very close together and there is a lot of sand. I checked my unlocked achievements on Steam and finding all the locations is not listed as an available one.

When I replay, all the journey steps are reset so I will never know if I have the one for leaving the land or not.

1 Like

I do not know where the location is.

:point_up:

It could be this one: https://conanexiles.gamepedia.com/Trailer_scene

As you are singleplayer-offline anyway, you can give it a try.

I have actually stumbled upon that cut-scene location before, was by total accident, when testing the admin commands and speed modifier on single player I ran through the ghost fence a few times while getting the hang of the maxed movement speed. On one occasion of this happening I got that cut scene where your character takes off their bracelet and walks out all epic like.

I can’t remember off the top of my head where abouts it was, but I might remember after logging in and having another look at the map, when I get home from work later I will check and if I find it I will update you on it’s coordinates :+1:

1 Like

PC users can teleport to the location. (outside map on SW/South side)

Ps4 wise, ghosting to location has yielded death in my attempts. The video for it has been taken down, so its basically just referenced from wikia and forms that it “can” be done.

Jen, Mention this is something there aware of.

Same as Mummy of Set, (which can be spawned, and kill option used) (PC anyway)
Mummy of Set seems to do nothing on consoles when i use it.

The character I use for LI farming and messing about is on those last 3. I havn’t found Youtube video that actually shows it being done.
Let me try and find it…

1 Like

@Croms_Faithful I feel your pain and asked this very same question a few months back. I’ve visited every location known within the game world, but it still won’t complete. Perhaps you’ll have better luck since you can use admin commands if need be.

Good luck!

1 Like

Hobo_The_Wise really!? That is very interesting. I have a couple of follow up questions if you dont mind? 1) do you remember, or can you show me a pic of where it was on the map that you triggered the cutscene 2) did triggering it log the final Journey Step ‘Escape the Exiled Lands’ as completed by doing it this way and take you back to the character creation screen or no?

Thanks for offering to check buddy.

That is ok Shadoza, there is nothing to forgive. But I have a follow up question. I know you tend to remove the bracelet and re-roll often. The next time you do so, can you please see if the game will allow you bring up the map screen while it plays, and note which grid it is on? No rush of course my friend, and only if and when you want to. Others are welcome to try this one too if they would like too.

Ok I check, however I can confirm that I have found botj The Highway and The Floe, and both are marked on my map.

No unfortunately I already tried the location you displayed, ie-the Introduction screen, but it did not trigger the Steps completion Jot.

done

1 Like

Don’t keep us waiting man, where is it? :sweat_smile:

I didn’t want to spoil it for anyone wanting to discover for their ownself. I sent a PM to Croms_Faithful

Spoiler Alert!

Image

2 Likes

Sure sure, that’s what they all say. :stuck_out_tongue:

Well looks like it’s out-of-reach for those of us on Officials regardless. :cry:

One could walk up to the wall in that area, but I didn’t notice a journey step trigger. You could walk through the wall; there is nothing in the way…but leaving the Exiled Lands in that fashion is a bit unkind and very deadly.

Yeah tried running and levitating all over the wall in that area even in single player and nothing happened.