Extremely slow Boot Time of my Server, up to 45 Minutes and more, please Help

Hi, i am hosting an Server for Conan Exiles (Exiled Lands) on Gportal, it recently became very active, so i had to clean out some inactive Bases ingame, aswell as Characters and Clans in the Savegame itself.

Ever since, i get the following Error in an Loop of 45 Minutes upon rebooting my Server:

[2022.11.04-04.21.32:746][ 0]LogPackageName:Warning: Please consider resaving package in order to speed-up loading.
[2022.11.04-04.21.44:950][ 0]LogPackageName: SearchForPackageOnDisk took 12.203s, but failed to resolve BasePlayerChar_C.
[2022.11.04-04.21.44:950][ 0]LogPackageName:Warning: String asset reference “BasePlayerChar_C” could not be resolved.
[2022.11.04-04.21.44:970][ 0]LogPackageName:Warning: String asset reference “BasePlayerChar_C” is in short form, which is unsupported and – even if valid – resolving it will be really slow.

It really takes 45 Minutes from me pressing Reboot, until it is ready for People to enter.

Gportal said, every Server has that Problem and it is normal. I have my Doubts here.

Yesterday i wiped the Server by Accident actually and it booted in under 20 Seconds. (It was only a Building Wipe, Characters- and Inventory stayed.).

The Server Age is around 3 Months now, but i keep it clean manually. No Mods are installed, none.

Cleanup means = Deleting Characters from the Table, then Accounts, then their Clans, in that Order, after that i destroy Leftovers of them ingame.

My Questions now =

  • Is there anything i am missing out on to fix these Log spamming Errors? Does everyone have the same Problem?
  • Am i cleaning up the wrong Way maybe? And if so, is there any better Way? (Without Mods.).
  • Is there any automated Way of cleaning up?

It is a big Pain to have to cleanup manually since Decay doesnt work at all, so any automated Script or alike would be very appreciated. The Decay Timer resets on each Reboot, which makes it useless, since we Reboot once a Day at minimum. Also People’s Stuff kept vanishing- and still does sometimes even with Decay off… Not even mentioning Thrall Decay killing all Thralls upon enabling.

Thanks for any Help in Advance, i am close to lose my Sanity over all this.

Ah, by the Way: One thing i was able to fix upon doing research here in the Forums before this Post. The Server Age doesnt reset to 0 anymore upon each Reboot, but that also didnt fix the Decay Problems.

1 Like

I don’t have the decay problem you do, nor the long boot times, but I have been searching for a way to retain my servers’ age and can’t seem to find an answer. How did you fix that?

1 Like

Odd, but imaginable since the server software is a huge buggy mess and extremely unoptimized.

Did you count the total building pieces and amount of placeables when this happened? Would be interesting to know.

You can create scripts that can do auto cleanup of player buildings based on the player’s last online time. If you have SQL Browser for SQLite you can inspect your game database.

I have marked the necessary column. It is an INTEGER and respresents UNIX-Time.
image

You then have to delete all objects associated with the player id (“id”) in the following 3 tables:

The green highlighted “owner_id” is the player id OR guild id.

For a cleanup, I also suggest removing characters and guilds from inactive players. This might be a bit too harsh though, because those players will lose all their progress then.

1 Like

Hello and thank you so much for that detailed Answer! :slight_smile:

Well, i only removed their Stuff from buildings (but this reappeared upon booting up, so i had to destroy it ingame manually by using ID’s) and their Characters and Clans. As soon as i remove anything from other Tables, my Server boots up without any Bases, but inbetween of 20 Secons booting it is ready, so i assume something is bugged about the Buildings on my Server.

I’m afraid that my Savegame might be corrupt, after only 2-3 Months of running the Server, because i planned not to wipe anytime soon… I will try one thing tough, as u mentioned buildable_health and building_instances, i will try to clean them too and check if the Error still exists. (It would make Sense, because while booting without any Buildings on the Server it took only 20 Seconds to be ready.).

I will report back when i’ve done this.

As for the Age Bug, i kind of followed that one:

Access your admin panel / management tool
1.1 If your server is not off turn it of before proceeding
1.2 If your server is off then proceed to step 2

Go to where the game.db file is stored for you, this entirely depends on how and with whom you’re hosting your server so in general it should be something along the lines of Conan Exiles\ConanSandbox\Saved
2.1 If you’re runnning multiple servers ensure that you’re in the data folder of the intended server that you are attempting to fix
2.2 Make a backup of the game.db file

Use a sqlite navigator tool, this would be a general use tool viable for most people https://sqlitebrowser.org/ 5
3.1 A decent guide on the tool is available here : Data Management with SQL for Social Scientists *alpha*: Using DB Browser for SQLite 8

Open the game.db file and navigate to the dw_settings table
4.1 Using the info in the guide provided above the step you should take from it are : Opening a database
4.2 The above step also details how to access tables so it should lead you do the right screen and there you will see the table

Check if this table has an entry where the name column is serverruntime
5.1 If there is an entry ensure that the data in the value column is of the format 3677564.48736522
5.1.1 If the entry is not similar to said format adjust it, using even the value above as it will correct itself
5.2 If there is no entry then you need to create it which can be done in the Browse data tab
5.2.1 Under the row of tabs you have a set of buttons one of them will state ‘Insert a new record in the current table’ when hovered
5.2.2 After clicking the button a new row will appear at the bottom of the list with null in both columns
5.2.3 In the left column you need to add in serverruntime and in the right column you can use 3677564.48736522, as stated previously this will get corrected right when the server is started back up

Now that will cover the cases where the entry is missing or poorly formatted and resulting in a default to 0 result. In case you have the entry in a valid format and still see your server reporting an age on 0 then this might relate to the nature of the values as they may be somehow invalid, the two numbers separated by a . appear to be in fact unix epoch timestamps and if they’re out of the epoch time bounds they will fail to translate and that could, though not so sure about this, result in a faulty computation, so in order to check that you could use Epoch Batch Conversion Tool 13 to determine what the two numbers would translate to.

Added the Column via SQL Command, and it was fixxed, though Decay is still not working at all, well atleast it shows the real Age now.

Were there mods present? That error about basplayerchar looks like you have a dead mod thats your problem.

I get you say not now, but that baseplayerchar error is suggestive.

Never used a Mod, it has been vanilla since launch.

If you take the game.db (assuming Exiled Lands) and load it into Singleplayer on your local machine, how long does it take to load?

@Zaydo, thank you very much for your answer about the Server Age. I have now fixed my servers. :+1:

Hi, i tried that now, it also took me 45 Minutes to get into the Game, that is a bad Sign, aint it?

Yeah unfortunately. That means its the database itself and not the provider.

Just as an example, I currently admin a server with about 2 mods and the database is a bit over a year old on the Savage Wilds map. It loads up in under 2-3 minutes still.

There MIGHT be a set of SQL commands that can solve this issue. But unfortunately I’m not exactly sure what is wrong here.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.