Failed to authenticate with character server

This have been a problem for me since a year ago, i try to play the game but i can’t pass the character selection.

Everytime i select my character and press the play button the loading screen stops when it begins to load the map and fade back to the login screen whith a massage: “failed to authenticate with character server”.

When i try to login again and i select my character to play, the game doesn’t try to load anymore, just a little window with a long lasting timer bar, that when it finish, kick me out of the game saying “operation timed out, try again later”
After several tries, i got a message saying the “required login data is missing. Please log in again. (22)”

something i must add:

  • i tried to log in with my other character, all are in Crom, they all had the same problem.
  • When this problem started, i could login with my character and play but if i had to move to another zone, for example, to raidfinder map, the game would kick me out of the game with “failed to authenticate with character server”.
  • i tried to login into another account, i had no problem playing until i had to move from the starting area to tortage, same as before, it kicked me out with “failed to authenticate”

Any ideas on how to fix this? i miss this game

It’s a known issue but as far as I know none of us figured it out, there are work arounds but not a “specific fix” per say… I have 2 work around, 1 - repair broken data and 2 - reset internet connection… cheers

1 Like

thank you! i had already tried those options with no success, i guess i’ll have to stay with the good memories of this game…

Do you have any chance to try to connect with a VPN? The last time I had an issue like that, connecting with a VPN fixed it.

This actually worked, thank you very much!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.