Following thralls and pets stop fighting all the time

Hi, maybe a week or more I have this problem on dedicated server. I recruit thrall, give him “follow” order. From start he attacks normally, but then suddenly stops. It’s the same with pets and thralls with weapon, there is no other pattern in this.

Tried swap weapons, leave them their default weapons, considering pets I left the default settings (attack all enemies), without succes. Anyone has the same problem? How do you solve this?

Thanks in advance

It is, I believe, a common problem. I don’t believe it has anything to do with “default” weapons* - that’s neither the cause nor the solution.

Whether there is any real solution I’ll leave to some of the more active players to chip in with.

*I don’t think that’s actually a thing - correct me if I’m wrong


Getting them hit sometimes snaps them out of these sorts of problems - have you tried giving them direct commands to send them into combat? Either ordering them to attack the specific target, or just ordering them to move to a position close to the target so it can aggro on them, should be an easy way to get them hit and might knock some sense back into them. I don’t know if it works for this specific behaviour bug (since I don’t seem to have had much trouble with it), but it’s definitely worked with a few of their strange behaviours…

Well yes, it happened before from time to time on every server. Now it’s almost guarantee it will happen eventually, every time I take thrall to the battle. Once it happens, it it undoable, the thrall is probably “broken” until the next server restart. :confused:

The only thrall who was ok and fighting few hours without stopping was greater wolf, the other always get bugged. Human thralls usually hit the enemy few times, then they hide their weapon to the inventory and when enemy approaches, he just stay in the battle mode, like ready to fist fight, and that’s it.

Yes, I tried that. before they get bugged, most of the commands work properly. But once the thrall is broken, attack command does nothing.Thrall would just follow me everywhere and when there is an enemy, he would only get into the fight position and stay passive.

1 Like

That might explain why I haven’t had the problem - in singleplayer, the server restarts a lot… I’m sorry the commands option doesn’t help. If I come up with any other ideas, I’ll suggest them. :confused:

1 Like

Thanks a lot! :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.