Free DLC unable to download for existing player UK

Game mode: [Online | Singleplayer]
Problem: [ Bug ]
Region: [UK]


Nudity Patch Free DLC unavailable in UK market unless new copy is purchased.

Hopefully setting this up correctly will get a mod on to reply as the previous topic for this was set up by someone in the wrong forum, didn’t really explain much and as such didn’t get any mod attention.

Okay, my issue

I purchased the digital preview version of Conan Exiles in the UK within the first week of its landing on Xbox, at that time the nudity patch was promised but some way off. Whilst I enjoyed playing, my attention span is limited so started playing other games and left Exiles to gather virtual dust on my Xbox.

Recently I decided I’d have another look at it as I had seen numerous large updates downloading on a regular basis over the course of time.

I opened the game to play again and no nudity still so looked online and saw that there was a seperate patch available due to an issue bundling it into the existing Xbox game.

I opened the Xbox Store only to find the game is now a full release with 3 different bundles, all of which include the nudity patch. There isn’t, however, a patch available for the version I purchased which means that I would have to pay for a new copy of the game just in order to get the
DLC which should already be available.

I’ve seen that I’m not the only one with this issue on the previous thread but like I said, it was a badly made thread so never received much attention.

Please post if you have the same issue, know a definite fix, are a mod or have an official statement from the devs.

This isn’t a regional issue regarding nudity, I am in the UK where the nudity patch is perfectly acceptable.

An official statement would be appreciated.

Thanks
SB


Steps on how to reproduce issue:

  1. Purchased Preview version prior to nudity patch. (Xbox UK)
  2. Try to download nudity patch (only available if I repurchase one of the bundles).
  3. Help!
  4. Thanks
1 Like

same issue here

This sounds like a system marketplace bug, which FunCom has no influence in.

Possible workarounds are search for the dlc pack by name in marketplace search field. Ensure your system is using the proper regional settings. Uninstall the game and reinstall using the dlc pack bundle link in the marketplace.

I realize that uninstall is pretty intensive due to the shear size of the game. It could run monthly traffic limits or take a long time, use this method as last resort.

it is not the uninstall that is the problem did thus twice now. the problem is that when I search for the dlc in the store it says it only come’s in a bundle. the bundle was released when the game was released. I owned the game a year before it was released as part of the “preview” program. I payed the full price for a game but I’m not recievin the full end product. I assume OP has the same issue(I have to rebuy the full game (which I already own)) to have acess to the “free” dlc

Somehow it seems, the bundle upgrade did not run smooth.
I have several variants of games bought as disc Version - also Conan Exiles.

The other games are shown as “installed” when I examine the store Versions. Somehow the shop does not figure out correctly, that your bundles are already installed and so allow to download the nude dlc.

I am wondering that none of the Masters took care of it yet. Your bug Report is completely fine.
From my point of view Funcom has to contact MS and figure this out together. It does not matter if the problem is by funcom or MS. The enduser has no chance in such cases, he/she depends on the funcom starting a dialogue with MS. The Season pack 2 was also something like this. Without Funcom talking to MS it would not have worked until now. MS gives a sh… on the enduser.

You get not so much Feedback because many people might not have the Problem just now.
But anyone from the EU arewa who owned CE before the bundle Upgrade can run into this by accident, so as it is a common problem it should be figured out asap!

This thread deserves a comment from funcom please.

1 Like

Thank you so much. you actually understand the issue. that made me smile :slight_smile:

Hey there,

We’ve sent note to our team to see if there’s an issue with this DLC.

Thank you, that’s great to hear.

1 Like

thank you

1 Like

So is this fixed because my son wants to know he’s about to head over to Oxford and he’s going to be taking this game from the US and wants to know if you’ll be able play the enhanced version that you guys get over there

nope, this issue has not yet been solved.

Still nothing… Any word from the devs?

1 Like

nope, nothing at all

Hello, we apologize for the delay in our response, we’re still waiting for additional information on this matter to share with you!

In the meantime, could you please confirm if your console’s Language and Location settings are correct?
If not, set them to match your country and make sure to also reboot your console before signing in to the store to check if the DLC has become available.

Edit: If the above doesn’t help, please send us your XBox Username and corresponding Email privately through DM ( to Hugo or Ignasis ), thanks!

4 Likes

yes. I did try this. had contact with microsoft support aswell after 2 hours of trying and looking they concluded that the issue is unfortunately on your end. do you have any mail adress I can send these to, or do I just message you?

1 Like

You may message me or Ignasis directly through these forums @montana1. :slight_smile:

2 Likes

I had the same issue, after uninstalling and reinstalling my game the DLC was no where to be found on the store, I waited a week or 2 then removed my account from the Xbox and re-added it again and the DLC showed up for me in the store again to reinstall, I hope this helps!

1 Like

I guess I’m having trouble sending you a direct message like my original statement was I moving to England and would like to get the free DLC but not sure if it will give to me because I’ve reset my Xbox for United Kingdom the second thing is I would like to see if there’s a way that I can buy the Royal guard to download that was given out for my dad’s Father’s Day

@Lyndzness Thank you for sharing that with us!

@Bearcoon Welcome to the forums! Do you own the digital preview version of Conan Exiles and are unable to get the Nudity DLC? I’m not entirely sure I understood what issue you’re having from your post, could you please rephrase it?

OK I do not have a digital copy of the game but if I need to I will buy it that way to get the free DLC the other thing was I’m trying to find out a way to get the original armor that was given to people the royal outfit in the game