Game crashing upon reaching character creation screen

**Game mode: Online Official and Private
**Type of issue: Crash
**Server type PVE-C
**Region: America

I took quite a long break from Conan. Not too long, actually, a couple of months, but I thought I’d get back into it with the Isle of Siptah being released.
No matter the server I’m on, the game crashes the second I’m past the cinematic and into what would be character creation. I never see my character or anything, it just flashes to a still image of some wreckage and then the game crashes. I’ve tried reinstalling conan, verifying files… Some forums mentioned an issues with mods but I’ve never had any, but still checked for any mods folder that might be suspect. Verified I’m not on a testlive patch or anything.
On a side note, tried joining a previous server. Character spawns in, but I briefly have a good 1 frame per second, before it too crashes.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.