Ghost Character Can't Get to Body

#1

My level 50 character is stuck in ghost form, since she died inside a locked room during a mission (“Appeasing the Flame”). There is no way to get to the body, as it’s inside the locked tomb; the door won’t open to her in ghost form, hence cannot rez. A cabal-mate suggested abandon the mission; I did that but nothing changed. I filed an in-game petition about a day ago, haven’t heard anything. This character is completely unplayable until this is fixed. /stuck and /reset both do nothing. Logging out and back on also no help. Any hints on how to fix this? There has been no response from Funcom support.

BTW: currently on a patron account. Getting frustrated that there has been no response to my in-game petition for a day.

#2

You don’t have to get back to your corpse. You can resurrect at any anima well.

You can also meet up on someone in another zone if for some reason you’re stuck in a place where you can no longer reach an anima well.

2 Likes
#3

Came to say what Aeryl said. Fun tip- you can explore the Breach, and get stuck, in Anima form. Had someone do that, so I went and got myself stuck in the same way, then figured out meet up in Anima form worked. :slight_smile:

2 Likes
#4

How do I rez at an anima well? It doesn’t offer an option to rez, and like I said trying /reset and /stuck don’t work. My character does re-appear in ghost form at an anima well when I log in.

#5

Just interact with it (F by default). It’ll pop up a dialogue box asking you if you want to resurrect, same as if you got close to your corpse.

1 Like
#6

DOH! Got to level 50 and didn’t know about this! Many thanks for the help, worked like a champ.

3 Likes
closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.