GPU driver update error message on startup. Game plays fine but monitor randomly shuts off and says “no signal.” Won’t turn on again until I manually shut off and start pc up again

Hoping someone can help me. It’s been a couple of days now and I’ve tried almost everything that was suggested on Reddit, plus extra.

So I get an error message when I first try to launch the game saying I need to update my graphics driver, and my monitor shuts off while I’m playing the game where it says “no signal.”

  1. I lowered the graphics

  2. I set the game to full screen

  3. I set to DX9

  4. My monitor is now only plugged into my GPU (Radeon RX 480) via HDMI only (beforehand I also had it plugged into the mobo via VGA. Woops.).

  5. I’ve capped FPS at 60.

  6. I did a clean uninstall and reinstall of my GPU software and drivers.

  7. I tried playing on Adrenalin Edition 18.5.1 before updating to the latest driver, Adrenalin Edition 18.9.2 . My monitor has been doing the same thing with both drivers.

If anything, it’s shutting off quicker now that I’ve done all of this than it did the first time around. Feeling really lost and frustrated. Please help.

This is my pc…

OS: Windows 7 64bit

CPU: Intel Core i5 6600

RAM: Crucial 2x4GB DDR4

MOBO: MSI H110M pro-vd plus

GPU: Radeon RX 480

Storage: 240GB SSD ATA

PSU: Seasonic G 550W 80+ Gold Certified semi modular ATX

Monitor: AOC 21.5” 1920x1080 75Hz

I’m sorry to hear about this issue. After a little research, I’ve found that this issue sometimes crops up with AMD graphics cards. If it’s what I’m thinking it is, the problem is that your PC is not stopping your monitor from going into standby.

I recommend that you go to power settings (Win 10: Right-click on desktop > Display Settings > Power & Sleep). Under “Screen”, set “When plugged in, turn off after” to “Never”. This should stop the monitor from doing this. You should make a habit of turning your monitor off manually when not in use while this is set to “Never”.

If the problem remains, then we’ll be happy to troubleshoot for you. Please contact us at help.funcom.com/ for tech support. Good luck with this and I hope you have a great day!

I know I’ve done that before with a different game but maybe the setting got changed back again? It’s just weird that it’s only this game. Not when I’m playing Second Life all day.The last time it happened, the game was running for maybe 5 mins and that’s it.

Hmm this is interesting. I have exactly same issues with my current PC, then again it happens with any game / program where my GPU is in high usage. I know where the issue is, my GPU is dying :frowning: AFAIK, Second Life is not that PC heavy? Can you test some other program too?

I tried to open Witcher 3 and see what it did but I seem to be having a probably unrelated issue with that (wouldn’t open and steam is difficult to open, had to click it like 20 times to finally get it open). I thought Second Life was pretty graphics heavy just because there’s so many variables all the time. I don’t think. My GPU isn’t dying because it’s only a year old.

Even a newish card can die early. Sometimes it is just bad hardware. Have you monitored GPU temperature leading up to this issue?

Ok, so I’m home from work now and that setting hasn’t changed.

“Turn off the display” is still set to “never.”

“Put the computer to sleep” is still set to “never.”

Hmm… no I haven’t. But I’m looking at the temps with all this going on, and the highest it’s gone is 150-160F. I searched google and read that it can max at 200F and that’s even with 50 degrees of buffer.

If you have access to another Graphics Card you could try, that would be one way of determining if the card is the issue, or something else.

Maybe try hooking up to another monitor that would test if monitor is giving problem. Try another cable/ connection to eliminate faulty cable or faulty connection. Trying to narrow down what could be causing the problem.

1 Like

It was two years ago; hopefully they figured it out. Hopefully.

1 Like

I imagine OP still troubleshooting the issue to his day, poor guy :frowning: