High Priest Journey Step 2, "Assign a High Priest to the Altar", doesn't register as completed (BUG)

Basic Info:

Platform: Steam
Issue Type: Gameplay
Game Mode: Single Player
Server Type: PvE
Map: Exiled Lands
Server Name: none - single player
Mods: =MODS= none

Bug Description:

Trying to complete the Journey “High Priest” you cannot complete step two “Assign a High Priest to the Altar”. The games doesn’t register that you complete this task.

Bug Reproduction:

Normal Gameplay with journey system for “high Priest”. Tried all the different altars and same issue. Tried in normal mode (finding/collecting/upgrading legit), admin mode, creative mode (spawning in mats/altars/thralls). Still the same issue, cannot complete in single player past this point. Unsure if it’s the same on unofficial or official servers.

1 Like

Yup, it’s a typo. It requires an arch priest instead.

1 Like

What Arch Priest?

Any arch priest (tier 3) or a named priest (tier 4) will fulfill this, so long as it’s the right shrine for the priest.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.