Holographic Helmet...Activate!

Game mode: [Offline | Singleplayer]
Problem: [Bug]
Region: [Here]

This is a strange cosmetic bug which has occured since the last update. Here we are, have a peek at the picture below and tell me what is amiss.

Basically if I equip a helmet (headgear) on a Thrall, I can remove it as usual and all seems well. However, upon server restart the thrall will appear to be wearing the helmet again, even though there isnt even one in their items! I can temporarily remedy this by equipping them with then removing a different helmet, however the past (ie-holographic) helmet will be back again after next server restart. This has happened with a seperate thrall wearing a Guardian helmet too. While this new holographic helmet may be great for fooling potential marauders passing by, my thralls arent skillful enough to operate it themselves. So the task always falls to me to deactivate it afterwards. Hugo or Ignasis can either of you fellows help me revoke their holo-helmet privilages…?

PS- this was only intended as light-hearted, good natured humor. Not as trolling, nastiness or rudeness. Just think of it as cheekiness; I love humor. Please keep up the great work!

Steps on how to reproduce issue:

  1. Equip a thrall with a helmet (headgear)
  2. Remove it
  3. Log off the server
  4. Log on again and notice it is back
  5. Equip and subsequently remove another to eliminate the ‘helmet’
  6. Repeat steps 4 & 5 any number of times
  7. Reprimand thralls for abuse of holo-helmet privileges

That is similar to what happened a few weeks ago with weapons and shield. You cheeky man. :grinning::hugs:


It happens with weapons and armor too Sestus…!? I had no idea. Can they still use them…well the holo-versions of them?

1 Like

For all your pieces of armor that do this, are they dyed? Dye any armor, equip it on a thrall, take it off, turn off the game and then back on again, and the graphic of the armor is still visible on them, but is not present in their inventory. At least this is what happened to me, all dyed armor stays on thralls. Like you said, the only way I found to stop it is to simply equip them with something else. Dyed armor is stuck permanently to them, even if you “remedy” it with non dyed armor. Take the latter off, reset the game and the original dyed armor bug returns. What I forgot to test is to see if NEW dyed armor permanently takes over the old.

However, I do not have that problem with armor that is NOT dyed. Can you tell me if all your rogue armor is dyed or not?

I even made a bug report on this some weeks back, it was considered low priority, which is understandable. But no naked thralls dancing around? :smiley:

If your rogue gear is NOT dyed, then it is a new problem. Also I was not aware this happened with weapons and shields as well.


Turns out the weapons and shields were on my inventory wheel when I had them equipped and I am trying to figure out how I gave them my stuff. Have not seen it happen lately.

Non naked thralls would concern me greatly :smirk:


Seems an old bug returning. A workaround we used when it first cropped up was, once you have the equipment that you wanted on the thrall. Have them follow take them a few steps away from where you wanted them and then place them back in their spot. This would make the system save the appearance properly.


No these pieces were NOT dyed in my game. As we can see on the picture above. And as far as my other thrall goes wearing the Guardian set, I felt it was already bright enough.

Wow that is bad! God Im glad I hadnt given them any dyed gear yet. Blast it…I finally start giving them better sets of armor and it blows up in my face. :confused: Gee Im hesitant to even dress them in ANYTHING now in case it is irreversible.

Im not sure it it is benign or low priority as they think. I guess that depends if the fix can reverse this and remove the graphical glitch.

No naked Dancers…!? Ohh the horror! :flushed: (Im not being sarcastic either)

Thanks Wak4863, ill try it out as soon as I get a chance and let you know how it went.


I do not have any of the armor that you have in your picture @Croms_Faithful, so I could not tell if it was dyed or not. But now this means there is my dyed problem, plus your issue as well. This means that some pieces of armor glitch this way, others not. (as I say I had done the test with non dyed armor I have)

Did you try @Wak4863’s trick? I will try it too when I play, busy with other things in the last days though.


Not yet Alhambra. Unfortunately, my work is extremely demanding even at the best of times, and so my playtime is usually restricted to weekends. So all going to plan I hope to test it out sometime this weekend. So ill let you know if it did the trick or not in the next couple of days @Wak4863.

Alhambra had you tried it out on your game yet, any success? If this doesnt work there will be no more headgear for my thralls (ill be instituting a ban), and even less gear issued to my Dancers!

Good news Wak4863, your old workaround still works! I have tested it on two thralls and both were a success. I hope to mark it as a ‘Solution’ for you soon, Im just waiting for a CM to sight this thread first so that it can be added to the to do list; even if its not a priority. Thanks for that Wak4863! @Alhambra just letting you know too buddy.


Good to hear the age old trick still works. :wink: it also works with war paint should you apply it to your thrall and it disappears on server restart.


Hello @Croms_Faithful, thank you for your report!

This issue is likely related to the one that has been previously reported by Alhambra in which removed dyed armor persisted on thralls after server restart, so we’ll update its ticket with this information.

We’ll also mark this topic as solved with Wak4863’s workaround so that others experiencing the issue have an easier time finding a temporary solution to it.


Sounds great Hugo, and thanks for marking Wak as a solution.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.