I fell trough the floor after inputting a pass. Why does it happen?

Approximately in the final chapter I stuck in a chair after inputting a password or I just fall through the floor. It happens when I see a big black thing in the window in the room of Icarus project. In the same room you must enter the EDEN password. I can’t continue the game so I ask for your support and an answer to the question. Thank you in advance.

Hello @suslo528, welcome to the community!

Have you tried to validate the integrity of the game files through Steam?

If this does not solve the issue, could you please share your savegame for us to look into?

You may find it within the “…\AppData\Local\MoonsOfMadness\Saved\SaveGames” folder.

Of course, I’ve tried to validate it but It didn’t help. Honestly, I have even tried to reboot my PC, reduce the graphics settings but none of that helped. Well, I don’t know how to attach files in this topic. Can I put that one on my Google Drive link?

That would be great, feel free to host them on the filesharing service of your preference and sharing the link privately with us through DM.

This site does not allow me to post links. How can I share the link with you?

We’ll reach out to you through DM.