Isle of Siptah Elixir of Freedom Bug

Game mode: Online private server
Type of issue: Bug with Elixir of Freedom
Server type: PVE
Region: Canada

When using the Elixir of Freedom it seems to work for about 3 seconds, then it drops to below what your stamina was before you took the Elixir even when it shows it still should be working, it also only gives 19 points of stamina as you can see not the 20 points the message says you should be getting.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. I ate and drank and made sure all was at 100%
    2.Took one Elixir of Freedom, notice it only give 19 points not 20
    3.Watch message come that I had it for 60mins and stamina go up
    4.A Few seconds later even though message is still on screen stamina goes down as soon on pictures to below what it was before potion was taken thus its a waste of the alter, the souls, the time and usage.

It seems like a big waste of time, a shrine and resources for a broken Elixir which will remove some of the stamina you already have after you take it, so it leaves you with less Stamina then before you took the Elixir.

Have you tried without mods btw? There was another person who insisted that eating food reduces their health because “hosav ui said so” but this is clearly not the case in the vanilla IoS game.

Maybe you can be so kind and to point out how the vanilla game UI will tell me anything about this at all. In case you have forgotten the vanilla UI gives no information at all other then a message about stamina increase, does not show how much health or stamina you have so no way to test it.

I have tried it in single player and as the UI gives no numbers about stamina or health or anything, its impossible to verify with out a mod to show you the numbers.

How do we know that it is not a Hosav UI bug then or caused by a mod? Again, I am not saying it is but I had a person trying really hard to convince me that eating food is reducing their HP because Hosav UI mod said so which is something you can test in vanilla easily. Forgive me for being a bit sceptical when it comes to your report.

EDIT: In vanilla you have this.

Before elixir:

After elixir:

A few mins later, still at 119. I can clip it for you if you like but you can test it yourself.

… and with 20 grit:


If you have any specific steps to reproduce the issue without mods, then I will be happy to re-confirm it for you.

1 Like