Jhebbal Sag Shrine Placement still bugged?

Game mode: [Enter game mode here: Online official
Type of issue: [Enter one of the following: Bug
Server type: [Enter one of the following: PvE
Region: US

Built a platform of foundations to place my Jhebbal of Sag, and it refuses to place. It either gives “not enough ground contact” (despite all evidence to the contrary) or overlaps with other object or terrain. I’m on island of siptah. I’ve tried rotation, raising/rotating, moving slightly off center in all directions, increasing the platform size to be larger. Nothing works. I see lots of old posts about this, and still no solution. I have other religion sect altars setup in exactly the same way, zero issues with those.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Build foundation
  2. Good luck placing shrine.

Last time I tried to place one it was still pretty finicky. In fact a lot of things seem a good bit more picky about where it’s placed now, but that Jhebbal Sag shrine is particularly bad. I have a suspicion that it’s because it gets so much more bulky when upgraded. In fact if I remember right, there’s actually a rather large new section coming out of it once upgraded that gives it a much larger footprint.

Yes some altars increases in size and require more space but I don’t remember exactly how much just made more room for it and it should place

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.